aboutsummaryrefslogtreecommitdiffstats
path: root/lib/Makefile.am
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-01-12 14:43:43 -0800
committerJosh Blum <josh@joshknows.com>2010-01-12 14:43:43 -0800
commitcbb8e474bb5592753a340ba31d3afbab7226f7c6 (patch)
tree6dd14d37d8d46f3a506a309f57d82ed1ed05f781 /lib/Makefile.am
parent4e94574aeaa46c671bba0a6fc83cb967d228c880 (diff)
downloaduhd-cbb8e474bb5592753a340ba31d3afbab7226f7c6.tar.gz
uhd-cbb8e474bb5592753a340ba31d3afbab7226f7c6.tar.bz2
uhd-cbb8e474bb5592753a340ba31d3afbab7226f7c6.zip
Reorganized structure into include, lib, test, firmware, fpga.
The fpga and firmware are empty placeholders for now.
Diffstat (limited to 'lib/Makefile.am')
-rw-r--r--lib/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/lib/Makefile.am b/lib/Makefile.am
new file mode 100644
index 000000000..efb655640
--- /dev/null
+++ b/lib/Makefile.am
@@ -0,0 +1,21 @@
+#
+# Copyright 2010 Ettus Research LLC
+#
+
+include $(top_srcdir)/Makefile.common
+
+SUBDIRS = usrp quadradio
+
+AM_CPPFLAGS = $(GENERAL_CPPFLAGS)
+
+lib_LTLIBRARIES = \
+ libusrp_uhd.la
+
+libusrp_uhd_la_SOURCES = \
+ device_addr.cpp \
+ usrp_uhd.cpp \
+ wax.cpp
+
+libusrp_uhd_la_LIBADD = $(GENERAL_LDDFLAGS)
+
+noinst_HEADERS =