aboutsummaryrefslogtreecommitdiffstats
path: root/images/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-08-06 18:49:23 -0700
committerJosh Blum <josh@joshknows.com>2010-08-06 18:49:23 -0700
commit777651148187bee83ab8ae0e4f752e3337cfb2ff (patch)
treeaa8cf7efdcf1448aaf59f99358f185bc786e008c /images/CMakeLists.txt
parent03ccbeb6411c0c13adf54bde4c19372ffa141aa0 (diff)
downloaduhd-777651148187bee83ab8ae0e4f752e3337cfb2ff.tar.gz
uhd-777651148187bee83ab8ae0e4f752e3337cfb2ff.tar.bz2
uhd-777651148187bee83ab8ae0e4f752e3337cfb2ff.zip
uhd-images: created makefile and cmake packager for the images
Diffstat (limited to 'images/CMakeLists.txt')
-rw-r--r--images/CMakeLists.txt42
1 files changed, 42 insertions, 0 deletions
diff --git a/images/CMakeLists.txt b/images/CMakeLists.txt
new file mode 100644
index 000000000..7a5056c4b
--- /dev/null
+++ b/images/CMakeLists.txt
@@ -0,0 +1,42 @@
+#
+# Copyright 2010 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+CMAKE_MINIMUM_REQUIRED(VERSION 2.6)
+PROJECT(UHD-images)
+
+########################################################################
+# Config Files (include order is important)
+########################################################################
+INCLUDE(${CMAKE_SOURCE_DIR}/../host/config/Python.cmake)
+INCLUDE(${CMAKE_SOURCE_DIR}/../host/config/Version.cmake)
+
+########################################################################
+# Setup CPack
+########################################################################
+SET(CPACK_PACKAGE_DESCRIPTION_SUMMARY "Ettus Research - Universal Hardware Driver Images")
+SET(CPACK_PACKAGE_VENDOR "Ettus Research LLC")
+SET(CPACK_PACKAGE_CONTACT "support@ettus.com")
+SET(CPACK_PACKAGE_VERSION_MAJOR ${UHD_VERSION_MAJOR})
+SET(CPACK_PACKAGE_VERSION_MINOR ${UHD_VERSION_MINOR})
+SET(CPACK_PACKAGE_VERSION_PATCH ${UHD_VERSION_PATCH})
+INCLUDE(CPack) #include after setting vars
+MESSAGE(STATUS "Version: ${CPACK_PACKAGE_VERSION}")
+
+########################################################################
+# Install Images
+########################################################################
+INSTALL(DIRECTORY ${CMAKE_SOURCE_DIR}/images DESTINATION share/uhd)