aboutsummaryrefslogtreecommitdiffstats
path: root/images/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-03-10 17:58:28 -0800
committerJosh Blum <josh@joshknows.com>2011-03-10 17:58:28 -0800
commit4dd34ae676eaed69538fe920f1d7c3b0cb9b8d82 (patch)
treed28ad15f431c967a6a71388e7ab6f77640e7b072 /images/CMakeLists.txt
parent414b7771e08f5925a1b5a924e24e860f2746101c (diff)
downloaduhd-4dd34ae676eaed69538fe920f1d7c3b0cb9b8d82.tar.gz
uhd-4dd34ae676eaed69538fe920f1d7c3b0cb9b8d82.tar.bz2
uhd-4dd34ae676eaed69538fe920f1d7c3b0cb9b8d82.zip
uhd-images: specify CPACK_PACKAGE_FILE_NAME so files names are platform independent
Diffstat (limited to 'images/CMakeLists.txt')
-rw-r--r--images/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/images/CMakeLists.txt b/images/CMakeLists.txt
index 705153baf..baac333ea 100644
--- a/images/CMakeLists.txt
+++ b/images/CMakeLists.txt
@@ -1,5 +1,5 @@
#
-# Copyright 2010 Ettus Research LLC
+# Copyright 2010-2011 Ettus Research LLC
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -32,6 +32,7 @@ SET(CPACK_PACKAGE_CONTACT "support@ettus.com")
SET(CPACK_PACKAGE_VERSION_MAJOR ${UHD_VERSION_MAJOR})
SET(CPACK_PACKAGE_VERSION_MINOR ${UHD_VERSION_MINOR})
SET(CPACK_PACKAGE_VERSION_PATCH ${UHD_VERSION_PATCH})
+SET(CPACK_PACKAGE_FILE_NAME "UHD-images-${UHD_VERSION_MAJOR}-${UHD_VERSION_MINOR}-${UHD_VERSION_PATCH}")
SET(CPACK_DEBIAN_PACKAGE_ARCHITECTURE "all")
INCLUDE(CPack) #include after setting vars
MESSAGE(STATUS "Version: ${CPACK_PACKAGE_VERSION}")