aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-04-28 22:44:13 -0700
committerJosh Blum <josh@joshknows.com>2011-04-28 22:44:13 -0700
commitf289d03d63b3e8f6009e1635ddcffbb196fb9eba (patch)
tree27308072e0c35c304d604f4eafb4335b2b07c893 /host/utils/CMakeLists.txt
parent424462cb99a3c4b12ac8a79ed9bb0670e1426cba (diff)
downloaduhd-f289d03d63b3e8f6009e1635ddcffbb196fb9eba.tar.gz
uhd-f289d03d63b3e8f6009e1635ddcffbb196fb9eba.tar.bz2
uhd-f289d03d63b3e8f6009e1635ddcffbb196fb9eba.zip
usrp2: include dd.exe in windows installers
uhd build system downloads dd.exe from ettus.com so we dont have to check it in
Diffstat (limited to 'host/utils/CMakeLists.txt')
-rw-r--r--host/utils/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/host/utils/CMakeLists.txt b/host/utils/CMakeLists.txt
index 98b5d41fb..b2dd697fc 100644
--- a/host/utils/CMakeLists.txt
+++ b/host/utils/CMakeLists.txt
@@ -54,6 +54,17 @@ FOREACH(util_source ${util_share_sources})
ENDFOREACH(util_source)
IF(ENABLE_USRP2)
+ IF(WIN32 AND UHD_RELEASE_MODE) #include dd.exe
+ FILE(DOWNLOAD
+ "http://www.ettus.com/downloads/dd.exe"
+ ${CMAKE_CURRENT_BINARY_DIR}/dd.exe
+ )
+ INSTALL(FILES
+ ${CMAKE_CURRENT_BINARY_DIR}/dd.exe
+ DESTINATION ${PKG_DATA_DIR}/utils
+ COMPONENT utilities
+ )
+ ENDIF(WIN32 AND UHD_RELEASE_MODE)
INSTALL(PROGRAMS
usrp2_recovery.py
usrp2_card_burner.py