aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2016-09-22 16:00:31 -0700
committerMartin Braun <martin.braun@ettus.com>2016-09-22 16:00:31 -0700
commita0ceeddc497188a8cce7e45ba5c7473636073247 (patch)
tree76e72184788dbd3bc0cc95d4bb9c4cdddb0b369f /host/utils/CMakeLists.txt
parentce6be04bc75f5dda2943fd438c055c57b70a11a6 (diff)
downloaduhd-a0ceeddc497188a8cce7e45ba5c7473636073247.tar.gz
uhd-a0ceeddc497188a8cce7e45ba5c7473636073247.tar.bz2
uhd-a0ceeddc497188a8cce7e45ba5c7473636073247.zip
cmake: Check for python requests, warn if not found (does not fail though)
Diffstat (limited to 'host/utils/CMakeLists.txt')
-rw-r--r--host/utils/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/host/utils/CMakeLists.txt b/host/utils/CMakeLists.txt
index 6f72c97bc..eb5a29df9 100644
--- a/host/utils/CMakeLists.txt
+++ b/host/utils/CMakeLists.txt
@@ -149,6 +149,9 @@ IF(LINUX)
COMPONENT utilities
)
ENDIF(LINUX)
+IF(NOT HAVE_PYTHON_MODULE_REQUESTS)
+ MESSAGE(WARNING "Module requests not found -- uhd_images_downloader.py will not work without it.")
+ENDIF(NOT HAVE_PYTHON_MODULE_REQUESTS)
IF(ENABLE_USRP2)
SET(burners