aboutsummaryrefslogtreecommitdiffstats
path: root/host/utils/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2015-01-26 12:17:17 +0100
committerMartin Braun <martin.braun@ettus.com>2015-10-19 17:33:17 -0700
commit508311768ad4f9538eecda16f1cae899ea31184b (patch)
tree5d244df138615d8fc055c07dc156cf72066af667 /host/utils/CMakeLists.txt
parent4a6c47682daff6fae533647487297967ae559c49 (diff)
downloaduhd-508311768ad4f9538eecda16f1cae899ea31184b.tar.gz
uhd-508311768ad4f9538eecda16f1cae899ea31184b.tar.bz2
uhd-508311768ad4f9538eecda16f1cae899ea31184b.zip
tools: Added converter benchmark tool
Diffstat (limited to 'host/utils/CMakeLists.txt')
-rw-r--r--host/utils/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/host/utils/CMakeLists.txt b/host/utils/CMakeLists.txt
index 4f56dad0d..1ef7766f9 100644
--- a/host/utils/CMakeLists.txt
+++ b/host/utils/CMakeLists.txt
@@ -56,10 +56,14 @@ UHD_INSTALL(TARGETS usrp_x3xx_fpga_burner RUNTIME DESTINATION ${RUNTIME_DIR} COM
# Utilities that get installed into the share path
########################################################################
SET(util_share_sources
+ converter_benchmark.cpp
query_gpsdo_sensors.cpp
usrp_burn_db_eeprom.cpp
usrp_burn_mb_eeprom.cpp
)
+SET(util_share_sources_py
+ converter_benchmark.py
+)
IF(ENABLE_USB)
LIST(APPEND util_share_sources
fx2_init_eeprom.cpp
@@ -109,6 +113,13 @@ FOREACH(util_source ${util_share_sources})
TARGET_LINK_LIBRARIES(${util_name} uhd ${Boost_LIBRARIES})
UHD_INSTALL(TARGETS ${util_name} RUNTIME DESTINATION ${PKG_LIB_DIR}/utils COMPONENT utilities)
ENDFOREACH(util_source)
+FOREACH(util_source ${util_share_sources_py})
+ UHD_INSTALL(PROGRAMS
+ ${CMAKE_CURRENT_SOURCE_DIR}/${util_source}
+ DESTINATION ${PKG_LIB_DIR}/utils
+ COMPONENT utilities
+ )
+ENDFOREACH(util_source)
UHD_INSTALL(TARGETS usrp_n2xx_simple_net_burner RUNTIME DESTINATION ${PKG_LIB_DIR}/utils COMPONENT utilities)
UHD_INSTALL(TARGETS usrp_x3xx_fpga_burner RUNTIME DESTINATION ${PKG_LIB_DIR}/utils COMPONENT utilities)