aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/devtest/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2015-10-26 16:45:47 -0700
committerMartin Braun <martin.braun@ettus.com>2015-11-11 10:37:26 -0800
commit88b0baeaf6dfa5f62f99ad53680108183ccc8721 (patch)
tree951e4f13742c9b3421ccb1bf059d77cabcff8626 /host/tests/devtest/CMakeLists.txt
parent201c5360cbb781ba93db408fb124a3bc44ffd383 (diff)
downloaduhd-88b0baeaf6dfa5f62f99ad53680108183ccc8721.tar.gz
uhd-88b0baeaf6dfa5f62f99ad53680108183ccc8721.tar.bz2
uhd-88b0baeaf6dfa5f62f99ad53680108183ccc8721.zip
tests: More devtests, works on E3XX now
- devtest now gets installed - uhd_usrp_probe test - Added make test_e3xx - Minor fixes to previous devtests
Diffstat (limited to 'host/tests/devtest/CMakeLists.txt')
-rw-r--r--host/tests/devtest/CMakeLists.txt22
1 files changed, 20 insertions, 2 deletions
diff --git a/host/tests/devtest/CMakeLists.txt b/host/tests/devtest/CMakeLists.txt
index c770446a6..6fa921bbd 100644
--- a/host/tests/devtest/CMakeLists.txt
+++ b/host/tests/devtest/CMakeLists.txt
@@ -1,3 +1,11 @@
+#
+# Copyright 2015 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
@@ -10,7 +18,14 @@
# Formatting
MESSAGE(STATUS "")
-#
+# All devtest files get installed:
+FILE(GLOB py_devtest_files "*.py")
+UHD_INSTALL(PROGRAMS
+ ${py_devtest_files}
+ DESTINATION ${PKG_LIB_DIR}/tests/devtest
+ COMPONENT tests
+)
+
# Arguments:
# - pattern: This will be used to identify which devtest_*.py is to be executed.
# - filter: Will be used in args strings as "type=<filter>".
@@ -19,7 +34,7 @@ MACRO(ADD_DEVTEST pattern filter devtype)
MESSAGE(STATUS "Adding ${devtype} device test target")
ADD_CUSTOM_TARGET("test_${pattern}"
${PYTHON_EXECUTABLE} ${CMAKE_CURRENT_SOURCE_DIR}/run_testsuite.py
- "--src-dir" "@CMAKE_CURRENT_SOURCE_DIR@"
+ "--src-dir" "${CMAKE_CURRENT_SOURCE_DIR}"
"--devtest-pattern" "${pattern}"
"--device-filter" "${filter}"
"--build-type" "${CMAKE_BUILD_TYPE}"
@@ -35,6 +50,9 @@ ENDIF(ENABLE_B200)
IF(ENABLE_X300)
ADD_DEVTEST("x3x0" "x300" "X3x0")
ENDIF(ENABLE_X300)
+IF(ENABLE_E300)
+ ADD_DEVTEST("e3xx" "e3x0" "E3XX")
+ENDIF(ENABLE_E300)
# Formatting
MESSAGE(STATUS "")