aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorLane Kolbly <lane.kolbly@ni.com>2021-10-18 16:45:46 -0500
committerAaron Rossetto <aaron.rossetto@ni.com>2021-11-03 06:04:19 -0700
commitc23dc3b0122a46353810d1ccbe98c08b080850e8 (patch)
treed89ab38b0565190737bd5e16b65c601f4df58fd6 /host/tests/CMakeLists.txt
parent3162b92bedda20f5b376137f5e918ebe07406fbb (diff)
downloaduhd-c23dc3b0122a46353810d1ccbe98c08b080850e8.tar.gz
uhd-c23dc3b0122a46353810d1ccbe98c08b080850e8.tar.bz2
uhd-c23dc3b0122a46353810d1ccbe98c08b080850e8.zip
host: x4xx: Implement GPIO API
This implements the GPIO API for X410 through get_gpio_attr and set_gpio_attr. In ATR mode, which channel's ATR state is chosen by the set_gpio_src call, setting e.g. DB0_RF0 for channel 0 or DB0_RF1 for channel 1. In manual mode, all 24 bits (for both ports) are set in a single register write. Although the front panel of the device has two ports, labelled GPIO0 and GPIO1, this API exposes them as though they were a single 24-bit GPIO port.
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index d3e44a518..a049c7e2e 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -370,6 +370,7 @@ UHD_ADD_RFNOC_BLOCK_TEST(
EXTRA_SOURCES
${UHD_SOURCE_DIR}/lib/usrp/common/lmx2572.cpp
${UHD_SOURCE_DIR}/lib/usrp/common/pwr_cal_mgr.cpp
+ ${UHD_SOURCE_DIR}/lib/usrp/x400/x400_gpio_control.cpp
${UHD_SOURCE_DIR}/lib/usrp/x400/x400_radio_control.cpp
${UHD_SOURCE_DIR}/lib/usrp/x400/x400_rfdc_control.cpp
${UHD_SOURCE_DIR}/lib/usrp/x400/adc_self_calibration.cpp
@@ -383,6 +384,7 @@ UHD_ADD_RFNOC_BLOCK_TEST(
${UHD_SOURCE_DIR}/lib/usrp/dboard/zbx/zbx_expert.cpp
${UHD_SOURCE_DIR}/lib/utils/compat_check.cpp
${UHD_SOURCE_DIR}/lib/features/discoverable_feature_registry.cpp
+ ${UHD_SOURCE_DIR}/lib/usrp/cores/gpio_atr_3000.cpp
$<TARGET_OBJECTS:uhd_rpclib>
INCLUDE_DIRS ${UHD_SOURCE_DIR}/lib/deps/rpclib/include
INCLUDE_DIRS ${UHD_SOURCE_DIR}/lib/deps/flatbuffers/include