aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorLars Amsel <lars.amsel@ni.com>2020-06-22 21:38:36 +0200
committerAaron Rossetto <aaron.rossetto@ni.com>2020-06-23 12:39:55 -0500
commita3ff904432d831702d47534f37a437304f5c55c1 (patch)
tree5b6716ddb4e4e0a319a4e58afdba3a2265fb4c62 /host/tests/CMakeLists.txt
parent2c8e79c92fe72eeb43cf1c13c961f689bfebdd15 (diff)
downloaduhd-a3ff904432d831702d47534f37a437304f5c55c1.tar.gz
uhd-a3ff904432d831702d47534f37a437304f5c55c1.tar.bz2
uhd-a3ff904432d831702d47534f37a437304f5c55c1.zip
test: Add verify-flatbuffer test
This runs update_fbs.py --verify as a unit test, and fail accordingly. The test passes if git executable is not found or the schema files are not within a git repo, because both are not a dependency of UHD.
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 44888c153..8c8a1cbc3 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -68,6 +68,7 @@ set(test_sources
# only differ in the cpp/py file extension). If in doubt, prepend 'py'
set(pytest_sources
pyranges_test.py
+ verify_fbs_test.py
)
#turn each test cpp file into an executable with an int main() function