aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2014-10-08 14:44:49 +0200
committerMartin Braun <martin.braun@ettus.com>2014-10-28 19:42:22 +0100
commit91347ea2cbf7618d4439548210eec940c582cbb8 (patch)
tree954a7fea956a80491449fe61b83793a2128b7388 /host/tests/CMakeLists.txt
parentc3be58b06c37a158ccb28a28436437920157a955 (diff)
downloaduhd-91347ea2cbf7618d4439548210eec940c582cbb8.tar.gz
uhd-91347ea2cbf7618d4439548210eec940c582cbb8.tar.bz2
uhd-91347ea2cbf7618d4439548210eec940c582cbb8.zip
uhd: Added sid_t
This is a data type to represent SIDs (stream IDs). It includes setters and getters for all components of the SID, converters to and from string and uint32 as well as C++ streams.
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 62544b69b..ea0b30cb8 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -37,6 +37,7 @@ SET(test_sources
msg_test.cpp
property_test.cpp
ranges_test.cpp
+ sid_t_test.cpp
sph_recv_test.cpp
sph_send_test.cpp
subdev_spec_test.cpp