aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Williams <alex.williams@ni.com>2019-11-04 15:54:35 -0800
committerMartin Braun <martin.braun@ettus.com>2019-11-26 12:21:33 -0800
commit70ed069b6e36b1823339cb0ac48f383c992de3b0 (patch)
tree9910b21f4ab84a81f6b2c1b51afed9a1a3f7f7e7 /host/tests/CMakeLists.txt
parent80ec3fee4298d5b0defd98db7dcf1a01f49e9778 (diff)
downloaduhd-70ed069b6e36b1823339cb0ac48f383c992de3b0.tar.gz
uhd-70ed069b6e36b1823339cb0ac48f383c992de3b0.tar.bz2
uhd-70ed069b6e36b1823339cb0ac48f383c992de3b0.zip
tests: Add check for life on DPDK port
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 4578a6307..d3c0b8e6a 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -115,6 +115,27 @@ endmacro(UHD_ADD_NONAPI_TEST)
###############################################################################
# Now add all unit tests that require special linkage
###############################################################################
+if(ENABLE_DPDK)
+ find_package(DPDK)
+ UHD_ADD_NONAPI_TEST(
+ TARGET "dpdk_port_test.cpp"
+ EXTRA_SOURCES
+ ${CMAKE_SOURCE_DIR}/lib/utils/config_parser.cpp
+ ${CMAKE_SOURCE_DIR}/lib/utils/paths.cpp
+ ${CMAKE_SOURCE_DIR}/lib/utils/pathslib.cpp
+ ${CMAKE_SOURCE_DIR}/lib/utils/prefs.cpp
+ ${CMAKE_SOURCE_DIR}/lib/transport/uhd-dpdk/dpdk_common.cpp
+ INCLUDE_DIRS
+ ${DPDK_INCLUDE_DIR}
+ EXTRA_LIBS ${DPDK_LIBRARIES}
+ NOAUTORUN # Don't register for auto-run, it requires special config
+ )
+ set_source_files_properties(
+ ${CMAKE_SOURCE_DIR}/lib/transport/uhd-dpdk/dpdk_common.cpp
+ PROPERTIES COMPILE_FLAGS "-march=native -D_GNU_SOURCE"
+ )
+ENDIF(ENABLE_DPDK)
+
UHD_ADD_NONAPI_TEST(
TARGET "system_time_test.cpp"
EXTRA_SOURCES