aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authormattprost <matt.prost@ni.com>2020-04-08 17:29:06 -0500
committerAaron Rossetto <aaron.rossetto@ni.com>2020-04-13 13:44:18 -0500
commit67918462210cd16c20075c939bdcf06992481a2c (patch)
tree0814e8191870337cfd916e0c9b49bf7cb2a77978 /host/tests/CMakeLists.txt
parenta9ce0fdd6a83e2800deaada59985a641fad6e900 (diff)
downloaduhd-67918462210cd16c20075c939bdcf06992481a2c.tar.gz
uhd-67918462210cd16c20075c939bdcf06992481a2c.tar.bz2
uhd-67918462210cd16c20075c939bdcf06992481a2c.zip
tests: migrated rfnoc block tests to dedicated subdirectory
This separates the rfnoc block tests into files for each specific block. This was done to improve the readability of these files and declutter the tests directory. Signed-off-by: mattprost <matt.prost@ni.com>
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt32
1 files changed, 25 insertions, 7 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index 828729b79..5fbdf04dd 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -117,6 +117,19 @@ macro(UHD_ADD_NONAPI_TEST)
endmacro(UHD_ADD_NONAPI_TEST)
###############################################################################
+# Add a unit test for an RFNoC block controller
+###############################################################################
+macro(UHD_ADD_RFNOC_BLOCK_TEST)
+ cmake_parse_arguments(test "NOAUTORUN" "TARGET" "INCLUDE_DIRS;EXTRA_SOURCES;EXTRA_LIBS" ${ARGN})
+ UHD_ADD_NONAPI_TEST(
+ TARGET rfnoc_block_tests/${test_TARGET}
+ EXTRA_SOURCES
+ ${test_EXTRA_SOURCES}
+ ${CMAKE_SOURCE_DIR}/lib/rfnoc/graph.cpp
+ )
+endmacro(UHD_ADD_RFNOC_BLOCK_TEST)
+
+###############################################################################
# Now add all unit tests that require special linkage
###############################################################################
if(ENABLE_DPDK)
@@ -245,16 +258,21 @@ set_source_files_properties(
PROPERTIES COMPILE_DEFINITIONS
"HAVE_MICROSEC_CLOCK"
)
-UHD_ADD_NONAPI_TEST(
- TARGET rfnoc_blocks_test.cpp
- EXTRA_SOURCES
- ${CMAKE_SOURCE_DIR}/lib/rfnoc/graph.cpp
+
+UHD_ADD_RFNOC_BLOCK_TEST(
+ TARGET ddc_block_test.cpp
)
-UHD_ADD_NONAPI_TEST(
+UHD_ADD_RFNOC_BLOCK_TEST(
+ TARGET duc_block_test.cpp
+)
+
+UHD_ADD_RFNOC_BLOCK_TEST(
TARGET fir_filter_block_test.cpp
- EXTRA_SOURCES
- ${CMAKE_SOURCE_DIR}/lib/rfnoc/graph.cpp
+)
+
+UHD_ADD_RFNOC_BLOCK_TEST(
+ TARGET null_block_test.cpp
)
UHD_ADD_NONAPI_TEST(