aboutsummaryrefslogtreecommitdiffstats
path: root/host/tests/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2019-09-30 13:18:19 +0200
committerBrent Stapleton <brent.stapleton@ettus.com>2019-10-07 11:38:25 -0700
commit15b10f9e8e2e98be8717a347304202c7aa171125 (patch)
treed981d7aec8793421180bad620bbe39d47f87f4f6 /host/tests/CMakeLists.txt
parentd33eb0efa8a90491a3f89e42c008f6602190714f (diff)
downloaduhd-15b10f9e8e2e98be8717a347304202c7aa171125.tar.gz
uhd-15b10f9e8e2e98be8717a347304202c7aa171125.tar.bz2
uhd-15b10f9e8e2e98be8717a347304202c7aa171125.zip
lib: utils: Add is_a_tty()
This is a portable version of POSIX's isatty(). Windows has its own version, called _isatty(). UHD thus gains its own, portable version. The underscores aren't beautiful, but they're necessary so we can distinguish the POSIX version from the UHD version.
Diffstat (limited to 'host/tests/CMakeLists.txt')
-rw-r--r--host/tests/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/tests/CMakeLists.txt b/host/tests/CMakeLists.txt
index a7d2120aa..769c09796 100644
--- a/host/tests/CMakeLists.txt
+++ b/host/tests/CMakeLists.txt
@@ -34,6 +34,7 @@ set(test_sources
fp_compare_delta_test.cpp
fp_compare_epsilon_test.cpp
gain_group_test.cpp
+ isatty_test.cpp
log_test.cpp
math_test.cpp
narrow_cast_test.cpp