aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/utils/chdr/CMakeLists.txt
diff options
context:
space:
mode:
authorSamuel O'Brien <sam.obrien@ni.com>2020-06-23 15:09:55 -0500
committerAaron Rossetto <aaron.rossetto@ni.com>2020-07-13 15:21:52 -0500
commit297d5855ca3ac2e3fea329bd938cf4763fac583b (patch)
treee302783f5efcadbd451d8d24463baece7d85a47c /host/lib/utils/chdr/CMakeLists.txt
parent22837edfe20feb57c24f2a55edbb65757b3fab6a (diff)
downloaduhd-297d5855ca3ac2e3fea329bd938cf4763fac583b.tar.gz
uhd-297d5855ca3ac2e3fea329bd938cf4763fac583b.tar.bz2
uhd-297d5855ca3ac2e3fea329bd938cf4763fac583b.zip
utils: Expose CHDR Parsing API
This commit introduces a new public api in uhd::utils which allows serializing and deserializing chdr packets. As far as testing, this commit adds the chdr_parse_test test. It uses a wireshark trace located in rfnoc_packets_*.cpp as well as hand coded packets from hardcoded_packets.cpp to test the serialization and deserialization process Signed-off-by: Samuel O'Brien <sam.obrien@ni.com>
Diffstat (limited to 'host/lib/utils/chdr/CMakeLists.txt')
-rw-r--r--host/lib/utils/chdr/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/host/lib/utils/chdr/CMakeLists.txt b/host/lib/utils/chdr/CMakeLists.txt
new file mode 100644
index 000000000..04f1180d4
--- /dev/null
+++ b/host/lib/utils/chdr/CMakeLists.txt
@@ -0,0 +1,9 @@
+#
+# Copyright 2020 Ettus Research, a National Instruments Brand
+#
+# SPDX-License-Identifier: GPL-3.0-or-later
+#
+
+LIBUHD_APPEND_SOURCES(
+ ${CMAKE_CURRENT_SOURCE_DIR}/chdr_packet.cpp
+)