aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp2/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-06-27 12:49:38 -0700
committerJosh Blum <josh@joshknows.com>2011-06-27 12:49:38 -0700
commitd9630428843f2510d99cb494435e4dc273652250 (patch)
treed7083a6c804dd0f7466b0ef0416c7183766f5fe4 /host/lib/usrp2/CMakeLists.txt
parent99eabb0a6b70a3bdb4f1cb0844894c4023dcd629 (diff)
downloaduhd-d9630428843f2510d99cb494435e4dc273652250.tar.gz
uhd-d9630428843f2510d99cb494435e4dc273652250.tar.bz2
uhd-d9630428843f2510d99cb494435e4dc273652250.zip
usrp2: work on setting up controllers
Diffstat (limited to 'host/lib/usrp2/CMakeLists.txt')
-rw-r--r--host/lib/usrp2/CMakeLists.txt33
1 files changed, 33 insertions, 0 deletions
diff --git a/host/lib/usrp2/CMakeLists.txt b/host/lib/usrp2/CMakeLists.txt
new file mode 100644
index 000000000..d7d6cc69f
--- /dev/null
+++ b/host/lib/usrp2/CMakeLists.txt
@@ -0,0 +1,33 @@
+#
+# Copyright 2011 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+LIBUHD_APPEND_SOURCES(
+ ${CMAKE_CURRENT_SOURCE_DIR}/clock_ctrl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/clock_ctrl.hpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/codec_ctrl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/codec_ctrl.hpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/fw_common.h
+ ${CMAKE_CURRENT_SOURCE_DIR}/usrp2_iface.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/usrp2_iface.hpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/usrp2_impl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/usrp2_impl.hpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/usrp2_regs.hpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/usrp2_clk_regs.hpp
+)