aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp/usrp_e100/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-11-09 18:48:54 -0800
committerJosh Blum <josh@joshknows.com>2010-11-09 18:48:54 -0800
commitd33a6cab6646692e06ef34317f6c831ac9c91148 (patch)
tree25bf8920fa9b69b66af7325da35b3e66daa51f66 /host/lib/usrp/usrp_e100/CMakeLists.txt
parent61d9cda7f64e10d8039bf7b6de5ca8068f11e5bb (diff)
downloaduhd-d33a6cab6646692e06ef34317f6c831ac9c91148.tar.gz
uhd-d33a6cab6646692e06ef34317f6c831ac9c91148.tar.bz2
uhd-d33a6cab6646692e06ef34317f6c831ac9c91148.zip
usrp_e: renamed directory to usrp_e100 to reflect product name
Diffstat (limited to 'host/lib/usrp/usrp_e100/CMakeLists.txt')
-rw-r--r--host/lib/usrp/usrp_e100/CMakeLists.txt64
1 files changed, 64 insertions, 0 deletions
diff --git a/host/lib/usrp/usrp_e100/CMakeLists.txt b/host/lib/usrp/usrp_e100/CMakeLists.txt
new file mode 100644
index 000000000..17ef53152
--- /dev/null
+++ b/host/lib/usrp/usrp_e100/CMakeLists.txt
@@ -0,0 +1,64 @@
+#
+# Copyright 2010 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+#This file will be included by cmake, use absolute paths!
+
+########################################################################
+# Conditionally configure the USRP-E100 support
+########################################################################
+MESSAGE(STATUS "Configuring USRP-E100 support...")
+
+INCLUDE(CheckIncludeFileCXX)
+CHECK_INCLUDE_FILE_CXX(linux/usrp_e.h HAVE_LINUX_USRP_E_H)
+
+SET(ENABLE_USRP_E TRUE)
+
+IF(DEFINED ENABLE_USRP_E100)
+ IF(ENABLE_USRP_E100)
+ MESSAGE(STATUS "USRP-E100 support enabled by configure flag")
+ ELSE(ENABLE_USRP_E100)
+ MESSAGE(STATUS "USRP-E100 support disabled by configure flag")
+ ENDIF(ENABLE_USRP_E100)
+ELSE(DEFINED ENABLE_USRP_E100) #not defined: automatic enabling of component
+ SET(ENABLE_USRP_E100 ${HAVE_LINUX_USRP_E_H})
+ENDIF(DEFINED ENABLE_USRP_E100)
+SET(ENABLE_USRP_E100 ${ENABLE_USRP_E100} CACHE BOOL "enable USRP-E100 support")
+
+IF(ENABLE_USRP_E100)
+ MESSAGE(STATUS " Building USRP-E100 support.")
+ LIBUHD_APPEND_SOURCES(
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_e100/clock_ctrl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_e100/clock_ctrl.hpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_e100/codec_ctrl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_e100/codec_ctrl.hpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_e100/codec_impl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_e100/dboard_impl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_e100/dboard_iface.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_e100/dsp_impl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_e100/fpga-downloader.cc
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_e100/io_impl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_e100/mboard_impl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_e100/usrp_e_impl.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_e100/usrp_e_impl.hpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_e100/usrp_e_iface.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_e100/usrp_e_iface.hpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_e100/usrp_e_mmap_zero_copy.cpp
+ ${CMAKE_SOURCE_DIR}/lib/usrp/usrp_e100/usrp_e_regs.hpp
+ )
+ELSE(ENABLE_USRP_E100)
+ MESSAGE(STATUS " Skipping USRP-E100 support.")
+ENDIF(ENABLE_USRP_E100)