aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp/usrp2/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-06-30 12:33:40 -0700
committerJosh Blum <josh@joshknows.com>2011-06-30 12:33:40 -0700
commit3a53fc9b19d1b1aed5f6c99367fe0f8e2911457c (patch)
tree1acbbaddc093da13df7b2456b1be49eea49f02c4 /host/lib/usrp/usrp2/CMakeLists.txt
parent6f4fb27955333ed9db372ec42aea52f3b605a968 (diff)
downloaduhd-3a53fc9b19d1b1aed5f6c99367fe0f8e2911457c.tar.gz
uhd-3a53fc9b19d1b1aed5f6c99367fe0f8e2911457c.tar.bz2
uhd-3a53fc9b19d1b1aed5f6c99367fe0f8e2911457c.zip
usrp2: restored component registry
Diffstat (limited to 'host/lib/usrp/usrp2/CMakeLists.txt')
-rw-r--r--host/lib/usrp/usrp2/CMakeLists.txt24
1 files changed, 16 insertions, 8 deletions
diff --git a/host/lib/usrp/usrp2/CMakeLists.txt b/host/lib/usrp/usrp2/CMakeLists.txt
index d16976060..10f7407b0 100644
--- a/host/lib/usrp/usrp2/CMakeLists.txt
+++ b/host/lib/usrp/usrp2/CMakeLists.txt
@@ -18,11 +18,19 @@
########################################################################
# This file included, use CMake directory variables
########################################################################
-LIBUHD_APPEND_SOURCES(
- ${CMAKE_CURRENT_SOURCE_DIR}/clock_ctrl.cpp
- ${CMAKE_CURRENT_SOURCE_DIR}/codec_ctrl.cpp
- ${CMAKE_CURRENT_SOURCE_DIR}/dboard_iface.cpp
- ${CMAKE_CURRENT_SOURCE_DIR}/io_impl.cpp
- ${CMAKE_CURRENT_SOURCE_DIR}/usrp2_iface.cpp
- ${CMAKE_CURRENT_SOURCE_DIR}/usrp2_impl.cpp
-)
+
+########################################################################
+# Conditionally configure the USRP2 support
+########################################################################
+LIBUHD_REGISTER_COMPONENT("USRP2" ENABLE_USRP2 ON "ENABLE_LIBUHD" OFF)
+
+IF(ENABLE_USRP2)
+ LIBUHD_APPEND_SOURCES(
+ ${CMAKE_CURRENT_SOURCE_DIR}/clock_ctrl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/codec_ctrl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/dboard_iface.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/io_impl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/usrp2_iface.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/usrp2_impl.cpp
+ )
+ENDIF(ENABLE_USRP2)