aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp/usrp1/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-09-09 15:53:04 -0700
committerJosh Blum <josh@joshknows.com>2010-09-09 15:53:04 -0700
commit72646d1960b0c979afec225e741d7d89a827c7d0 (patch)
tree54d40fc75cf1ded6cb428a3606e88c371b3816f1 /host/lib/usrp/usrp1/CMakeLists.txt
parentddfcc114bfd6d37c182a3279368852f4b96f9ffd (diff)
downloaduhd-72646d1960b0c979afec225e741d7d89a827c7d0.tar.gz
uhd-72646d1960b0c979afec225e741d7d89a827c7d0.tar.bz2
uhd-72646d1960b0c979afec225e741d7d89a827c7d0.zip
uhd: added enable flags for usrp1 and usrp2
Diffstat (limited to 'host/lib/usrp/usrp1/CMakeLists.txt')
-rw-r--r--host/lib/usrp/usrp1/CMakeLists.txt32
1 files changed, 20 insertions, 12 deletions
diff --git a/host/lib/usrp/usrp1/CMakeLists.txt b/host/lib/usrp/usrp1/CMakeLists.txt
index 229a4ce63..67487f99e 100644
--- a/host/lib/usrp/usrp1/CMakeLists.txt
+++ b/host/lib/usrp/usrp1/CMakeLists.txt
@@ -20,18 +20,26 @@
########################################################################
# Conditionally configure the USRP1 support
########################################################################
-MESSAGE(STATUS "Configuring usrp1 support...")
+MESSAGE(STATUS "Configuring USRP1 support...")
-IF(HAVE_USB_SUPPORT)
- MESSAGE(STATUS "Has USB support - found")
-ELSE(HAVE_USB_SUPPORT)
- MESSAGE(STATUS "Has USB support - not found")
-ENDIF(HAVE_USB_SUPPORT)
+IF(DEFINED ENABLE_USRP1)
+ IF(ENABLE_USRP1)
+ MESSAGE(STATUS "USRP1 support enabled by configure flag")
+ ELSE(ENABLE_USRP1)
+ MESSAGE(STATUS "USRP1 support disabled by configure flag")
+ ENDIF(ENABLE_USRP1)
+ELSE(DEFINED ENABLE_USRP1) #not defined: automatic enabling of component
+ SET(ENABLE_USRP1 ${HAVE_USB_SUPPORT})
+ENDIF(DEFINED ENABLE_USRP1)
+SET(ENABLE_USRP1 ${ENABLE_USRP1} CACHE BOOL "enable USRP1 support")
-#TODO check for usrp1 enable/disable option flag
+#sanity check when USRP1 support enabled
+IF(ENABLE_USRP1 AND NOT HAVE_USB_SUPPORT)
+ MESSAGE(FATAL_ERROR "USRP1 support enabled without USB support")
+ENDIF(ENABLE_USRP1 AND NOT HAVE_USB_SUPPORT)
-IF(HAVE_USB_SUPPORT)
- MESSAGE(STATUS " Building usrp1 support.")
+IF(ENABLE_USRP1)
+ MESSAGE(STATUS " Building USRP1 support.")
INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/../firmware/fx2/include)
LIBUHD_APPEND_SOURCES(
@@ -52,6 +60,6 @@ IF(HAVE_USB_SUPPORT)
${CMAKE_SOURCE_DIR}/lib/usrp/usrp1/usrp1_ctrl.cpp
${CMAKE_SOURCE_DIR}/lib/usrp/usrp1/usrp1_ctrl.hpp
)
-ELSE(HAVE_USB_SUPPORT)
- MESSAGE(STATUS " Skipping usrp1 support.")
-ENDIF(HAVE_USB_SUPPORT)
+ELSE(ENABLE_USRP1)
+ MESSAGE(STATUS " Skipping USRP1 support.")
+ENDIF(ENABLE_USRP1)