aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp/netd/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrej Rode <andrej.rode@ettus.com>2017-03-27 18:05:23 -0700
committerMartin Braun <martin.braun@ettus.com>2017-12-22 15:03:45 -0800
commitc8ae32253b649faea27dcf0d98fd0395924a2eec (patch)
tree8ce89838769d7043f06cb8dc7285b269f9754498 /host/lib/usrp/netd/CMakeLists.txt
parent53795c74aead4e6021bc788b788f8ed5b4a0166d (diff)
downloaduhd-c8ae32253b649faea27dcf0d98fd0395924a2eec.tar.gz
uhd-c8ae32253b649faea27dcf0d98fd0395924a2eec.tar.bz2
uhd-c8ae32253b649faea27dcf0d98fd0395924a2eec.zip
usrp: add netd find and impl, add uhd rpc client wrapper
Diffstat (limited to 'host/lib/usrp/netd/CMakeLists.txt')
-rw-r--r--host/lib/usrp/netd/CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/host/lib/usrp/netd/CMakeLists.txt b/host/lib/usrp/netd/CMakeLists.txt
new file mode 100644
index 000000000..a33c978c8
--- /dev/null
+++ b/host/lib/usrp/netd/CMakeLists.txt
@@ -0,0 +1,29 @@
+#
+# Copyright 2017 Ettus Research (National Instruments)
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+
+########################################################################
+# Conditionally configure the X300 support
+########################################################################
+IF(ENABLE_NETD)
+ LIBUHD_APPEND_SOURCES(
+ ${CMAKE_CURRENT_SOURCE_DIR}/netd_impl.cpp
+ )
+ENDIF(ENABLE_NETD)