aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp/mpmd/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2017-05-20 17:44:01 -0700
committerMartin Braun <martin.braun@ettus.com>2017-12-22 15:03:53 -0800
commit65713fa6f5dd534da1dcc34a7fb4baeeccc5d4c8 (patch)
treea74dea5917586450d4fc2e3a8ba5a17103eae9f5 /host/lib/usrp/mpmd/CMakeLists.txt
parent1ce038094d3b0d5021601533a3dbccbffa229574 (diff)
downloaduhd-65713fa6f5dd534da1dcc34a7fb4baeeccc5d4c8.tar.gz
uhd-65713fa6f5dd534da1dcc34a7fb4baeeccc5d4c8.tar.bz2
uhd-65713fa6f5dd534da1dcc34a7fb4baeeccc5d4c8.zip
Rename netd to mpmd
Diffstat (limited to 'host/lib/usrp/mpmd/CMakeLists.txt')
-rw-r--r--host/lib/usrp/mpmd/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/host/lib/usrp/mpmd/CMakeLists.txt b/host/lib/usrp/mpmd/CMakeLists.txt
new file mode 100644
index 000000000..5ff1f36eb
--- /dev/null
+++ b/host/lib/usrp/mpmd/CMakeLists.txt
@@ -0,0 +1,26 @@
+#
+# Copyright 2017 Ettus Research (National Instruments)
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+
+IF(ENABLE_MPMD)
+ LIBUHD_APPEND_SOURCES(
+ ${CMAKE_CURRENT_SOURCE_DIR}/mpmd_impl.cpp
+ )
+ENDIF(ENABLE_MPMD)