aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp/mpmd/CMakeLists.txt
diff options
context:
space:
mode:
authorSamuel O'Brien <sam.obrien@ni.com>2020-07-24 08:35:35 -0500
committerAaron Rossetto <aaron.rossetto@ni.com>2020-10-28 15:25:48 -0500
commit00c306d5c441e60e7dfd2516e05e4e433977ecee (patch)
tree998752676d4ff9dbd06ad194056a214e7fdc763c /host/lib/usrp/mpmd/CMakeLists.txt
parentbd278a4b936f3e30f51d7cb9ff489f3ff7215379 (diff)
downloaduhd-00c306d5c441e60e7dfd2516e05e4e433977ecee.tar.gz
uhd-00c306d5c441e60e7dfd2516e05e4e433977ecee.tar.bz2
uhd-00c306d5c441e60e7dfd2516e05e4e433977ecee.zip
sim: Integrate simulator into UHD
This commit adds a device::register_device which allows uhd to start up a simulator when uhd is called with the arguments type=sim. Creating the device object creates a subprocess using pybind and an embedded interpreter, and destroying the object cleans up those subprocesses. Signed-off-by: Samuel O'Brien <sam.obrien@ni.com>
Diffstat (limited to 'host/lib/usrp/mpmd/CMakeLists.txt')
-rw-r--r--host/lib/usrp/mpmd/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/host/lib/usrp/mpmd/CMakeLists.txt b/host/lib/usrp/mpmd/CMakeLists.txt
index 6604ba5a8..d7f7f93a2 100644
--- a/host/lib/usrp/mpmd/CMakeLists.txt
+++ b/host/lib/usrp/mpmd/CMakeLists.txt
@@ -18,6 +18,12 @@ if(ENABLE_MPMD)
${CMAKE_CURRENT_SOURCE_DIR}/mpmd_link_if_ctrl_udp.cpp
)
+ if(ENABLE_SIM)
+ LIBUHD_APPEND_SOURCES(
+ ${CMAKE_CURRENT_SOURCE_DIR}/sim_find.cpp
+ )
+ endif(ENABLE_SIM)
+
if(ENABLE_DPDK)
include_directories(${DPDK_INCLUDE_DIRS})
set_property(