aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp/e100/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-06-17 15:37:30 -0700
committerJosh Blum <josh@joshknows.com>2011-06-17 15:37:30 -0700
commit2e401993b5b3e8920017729f4325ff5a51790fa5 (patch)
tree51f904c8fa927cc55586b9b05e319fa089da8c79 /host/lib/usrp/e100/CMakeLists.txt
parenta852b6011c11e32e000ccd18c2009edfe81500ee (diff)
downloaduhd-2e401993b5b3e8920017729f4325ff5a51790fa5.tar.gz
uhd-2e401993b5b3e8920017729f4325ff5a51790fa5.tar.bz2
uhd-2e401993b5b3e8920017729f4325ff5a51790fa5.zip
e100: removed usrp from directory prefix
Diffstat (limited to 'host/lib/usrp/e100/CMakeLists.txt')
-rw-r--r--host/lib/usrp/e100/CMakeLists.txt49
1 files changed, 49 insertions, 0 deletions
diff --git a/host/lib/usrp/e100/CMakeLists.txt b/host/lib/usrp/e100/CMakeLists.txt
new file mode 100644
index 000000000..15133ad5e
--- /dev/null
+++ b/host/lib/usrp/e100/CMakeLists.txt
@@ -0,0 +1,49 @@
+#
+# Copyright 2010-2011 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+
+########################################################################
+# Conditionally configure the USRP-E100 support
+########################################################################
+LIBUHD_REGISTER_COMPONENT("USRP-E100" ENABLE_E100 OFF "ENABLE_LIBUHD;LINUX" OFF)
+
+IF(ENABLE_E100)
+ INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR}/include)
+
+ LIBUHD_APPEND_SOURCES(
+ ${CMAKE_CURRENT_SOURCE_DIR}/clock_ctrl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/clock_ctrl.hpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/codec_ctrl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/codec_ctrl.hpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/codec_impl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/dboard_impl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/dboard_iface.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/dsp_impl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/fpga_downloader.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/io_impl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/mboard_impl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e100_impl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e100_impl.hpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e100_iface.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e100_iface.hpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e100_mmap_zero_copy.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e100_regs.hpp
+ )
+ENDIF(ENABLE_E100)