aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp/dboard/eiscat/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2017-05-03 15:49:10 -0700
committerMartin Braun <martin.braun@ettus.com>2017-12-22 15:03:52 -0800
commita0ded71188aa96282736a9bc13a086b71f92d965 (patch)
tree71bbb83299d9c55c5eafc4b019745c9c569f2c10 /host/lib/usrp/dboard/eiscat/CMakeLists.txt
parentaf35903d17d8cd314a2626f38eded72956459e23 (diff)
downloaduhd-a0ded71188aa96282736a9bc13a086b71f92d965.tar.gz
uhd-a0ded71188aa96282736a9bc13a086b71f92d965.tar.bz2
uhd-a0ded71188aa96282736a9bc13a086b71f92d965.zip
eiscat: Added skeleton for dboard driver support
Diffstat (limited to 'host/lib/usrp/dboard/eiscat/CMakeLists.txt')
-rw-r--r--host/lib/usrp/dboard/eiscat/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/host/lib/usrp/dboard/eiscat/CMakeLists.txt b/host/lib/usrp/dboard/eiscat/CMakeLists.txt
new file mode 100644
index 000000000..bd55dcc14
--- /dev/null
+++ b/host/lib/usrp/dboard/eiscat/CMakeLists.txt
@@ -0,0 +1,24 @@
+#
+# Copyright 2017 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+IF(ENABLE_NETD AND ENABLE_EISCAT)
+ LIST(APPEND EISCAT_SOURCES
+ ${CMAKE_CURRENT_SOURCE_DIR}/eiscat_radio_ctrl_impl.cpp
+ )
+ LIBUHD_APPEND_SOURCES(${EISCAT_SOURCES})
+ENDIF(ENABLE_NETD AND ENABLE_EISCAT)
+