aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp/dboard/e3xx/CMakeLists.txt
diff options
context:
space:
mode:
authorSugandha Gupta <sugandha.gupta@ettus.com>2019-01-25 11:34:47 -0800
committerBrent Stapleton <brent.stapleton@ettus.com>2019-05-01 15:17:23 -0700
commit178b35569b1a25180a80a23b945b10b04c9f10f5 (patch)
tree3adb6f78ebd148867a50526c60fe7bf9694a4a72 /host/lib/usrp/dboard/e3xx/CMakeLists.txt
parent8a400f6a30942c9d6d3596f6989720eb4cff058b (diff)
downloaduhd-178b35569b1a25180a80a23b945b10b04c9f10f5.tar.gz
uhd-178b35569b1a25180a80a23b945b10b04c9f10f5.tar.bz2
uhd-178b35569b1a25180a80a23b945b10b04c9f10f5.zip
e310/e320: Move E310 to MPM architecture and refactor
- Turns the E310 into an MPM device (like N3xx, E320) - Factor out common code between E320 and E310, maximize sharing between the two devices - Remove all pre-MPM E310 code that is no longer needed - Modify MPM to remove all existing overlays before applying new ones (this is necessary to enable idle image mode for E310) Co-authored-by: Virendra Kakade <virendra.kakade@ni.com> Signed-off-by: Virendra Kakade <virendra.kakade@ni.com>
Diffstat (limited to 'host/lib/usrp/dboard/e3xx/CMakeLists.txt')
-rw-r--r--host/lib/usrp/dboard/e3xx/CMakeLists.txt31
1 files changed, 31 insertions, 0 deletions
diff --git a/host/lib/usrp/dboard/e3xx/CMakeLists.txt b/host/lib/usrp/dboard/e3xx/CMakeLists.txt
new file mode 100644
index 000000000..36376cd88
--- /dev/null
+++ b/host/lib/usrp/dboard/e3xx/CMakeLists.txt
@@ -0,0 +1,31 @@
+#
+# Copyright 2018 Ettus Research, a National Instruments Company
+#
+# SPDX-License-Identifier: GPL-3.0-or-later
+#
+
+IF(ENABLE_E300 OR ENABLE_E320)
+ LIST(APPEND E3XX_SOURCES
+ ${CMAKE_CURRENT_SOURCE_DIR}/e3xx_radio_ctrl_impl.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e3xx_radio_ctrl_init.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e3xx_ad9361_iface.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/e3xx_bands.cpp
+ )
+ LIBUHD_APPEND_SOURCES(${E3XX_SOURCES})
+ENDIF(ENABLE_E300 OR ENABLE_E320)
+
+IF(ENABLE_E300)
+ MESSAGE(STATUS "E300 Enabled")
+ LIST(APPEND E300_SOURCES
+ ${CMAKE_CURRENT_SOURCE_DIR}/e31x_radio_ctrl_impl.cpp
+ )
+ LIBUHD_APPEND_SOURCES(${E300_SOURCES})
+ENDIF(ENABLE_E300)
+
+IF(ENABLE_E320)
+ MESSAGE(STATUS "E320 Enabled")
+ LIST(APPEND E320_SOURCES
+ ${CMAKE_CURRENT_SOURCE_DIR}/e320_radio_ctrl_impl.cpp
+ )
+ LIBUHD_APPEND_SOURCES(${E320_SOURCES})
+ENDIF(ENABLE_E320)