aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/usrp/common/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-07-01 16:54:53 -0700
committerJosh Blum <josh@joshknows.com>2011-07-01 16:54:53 -0700
commit614d4901bb9dbb6866a0c5f57b1397e4b185a11f (patch)
treed2c0308af2464ae3b15e2079a25d8f24d46f0caa /host/lib/usrp/common/CMakeLists.txt
parent6aa4690af05559d28b5238fa153fd46ff57cf06f (diff)
downloaduhd-614d4901bb9dbb6866a0c5f57b1397e4b185a11f.tar.gz
uhd-614d4901bb9dbb6866a0c5f57b1397e4b185a11f.tar.bz2
uhd-614d4901bb9dbb6866a0c5f57b1397e4b185a11f.zip
usrp: created common code to demux an rx stream (b100, e100)
Diffstat (limited to 'host/lib/usrp/common/CMakeLists.txt')
-rw-r--r--host/lib/usrp/common/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/host/lib/usrp/common/CMakeLists.txt b/host/lib/usrp/common/CMakeLists.txt
index 31004d952..ec8b60fec 100644
--- a/host/lib/usrp/common/CMakeLists.txt
+++ b/host/lib/usrp/common/CMakeLists.txt
@@ -20,10 +20,15 @@
########################################################################
IF(ENABLE_USB)
INCLUDE_DIRECTORIES(${CMAKE_SOURCE_DIR}/../firmware/fx2/common)
- INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
LIBUHD_APPEND_SOURCES(
${CMAKE_CURRENT_SOURCE_DIR}/fx2_ctrl.cpp
- ${CMAKE_CURRENT_SOURCE_DIR}/validate_subdev_spec.cpp
)
ENDIF(ENABLE_USB)
+
+INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
+
+LIBUHD_APPEND_SOURCES(
+ ${CMAKE_CURRENT_SOURCE_DIR}/validate_subdev_spec.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/recv_packet_demuxer.cpp
+)