aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/transport/CMakeLists.txt
diff options
context:
space:
mode:
authorMoritz Fischer <moritz.fischer@ettus.com>2017-06-06 15:43:56 -0700
committerMoritz Fischer <moritz.fischer@ettus.com>2017-08-07 16:09:43 -0700
commited1c64c8196520c40dbfe406d7c54f2907f3b0fb (patch)
treed32222af9bae166a782066893563e6bd7a3740b6 /host/lib/transport/CMakeLists.txt
parent61b52e5113dbe25ba0d83a135c34532de543542e (diff)
downloaduhd-ed1c64c8196520c40dbfe406d7c54f2907f3b0fb.tar.gz
uhd-ed1c64c8196520c40dbfe406d7c54f2907f3b0fb.tar.bz2
uhd-ed1c64c8196520c40dbfe406d7c54f2907f3b0fb.zip
transport: Added liberio_zero_copy transport implementation
This adds a zero copy transport using the liberio library. Currently supported API version for liberio is 0.3, this might still very much break, since the library is still in development. So far nobody uses it UHD so we might as well merge it. Signed-off-by: Alex Williams <alex.williams@ni.com> Signed-off-by: Moritz Fischer <moritz.fischer@ettus.com>
Diffstat (limited to 'host/lib/transport/CMakeLists.txt')
-rw-r--r--host/lib/transport/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/host/lib/transport/CMakeLists.txt b/host/lib/transport/CMakeLists.txt
index a6d84cc4a..c8fd16ef3 100644
--- a/host/lib/transport/CMakeLists.txt
+++ b/host/lib/transport/CMakeLists.txt
@@ -138,6 +138,16 @@ IF(ENABLE_X300)
)
ENDIF(ENABLE_X300)
+IF(ENABLE_LIBERIO)
+ MESSAGE(STATUS "")
+ MESSAGE(STATUS "liberio support enabled.")
+ INCLUDE_DIRECTORIES(${LIBERIO_INCLUDE_DIRS})
+ LIBUHD_APPEND_LIBS(${LIBERIO_LIBRARIES})
+ LIBUHD_APPEND_SOURCES(
+ ${CMAKE_CURRENT_SOURCE_DIR}/liberio_zero_copy.cpp
+ )
+ENDIF(ENABLE_LIBERIO)
+
# Verbose Debug output for send/recv
SET( UHD_TXRX_DEBUG_PRINTS OFF CACHE BOOL "Use verbose debug output for send/recv" )
OPTION( UHD_TXRX_DEBUG_PRINTS "Use verbose debug output for send/recv" "" )