aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/transport/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-06-08 00:00:54 -0700
committerJosh Blum <josh@joshknows.com>2010-06-08 00:00:54 -0700
commitd0039bd4128eed56acccce7b20c913afa8cb7381 (patch)
tree953c6088ef6f8775c61c7beac59a47a9e36e3774 /host/lib/transport/CMakeLists.txt
parent11e2d407ce4a45da8c6981abfd34883cb9174840 (diff)
downloaduhd-d0039bd4128eed56acccce7b20c913afa8cb7381.tar.gz
uhd-d0039bd4128eed56acccce7b20c913afa8cb7381.tar.bz2
uhd-d0039bd4128eed56acccce7b20c913afa8cb7381.zip
Replaced convert types with generated convert types that handles more cases.
Added unit test for generated converter.
Diffstat (limited to 'host/lib/transport/CMakeLists.txt')
-rw-r--r--host/lib/transport/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/host/lib/transport/CMakeLists.txt b/host/lib/transport/CMakeLists.txt
index a74f7d527..872865d6c 100644
--- a/host/lib/transport/CMakeLists.txt
+++ b/host/lib/transport/CMakeLists.txt
@@ -44,8 +44,12 @@ LIBUHD_PYTHON_GEN_SOURCE(
${CMAKE_BINARY_DIR}/lib/transport/vrt.cpp
)
+LIBUHD_PYTHON_GEN_SOURCE(
+ ${CMAKE_SOURCE_DIR}/lib/transport/gen_convert_types.py
+ ${CMAKE_BINARY_DIR}/lib/transport/convert_types.cpp
+)
+
LIBUHD_APPEND_SOURCES(
- ${CMAKE_SOURCE_DIR}/lib/transport/convert_types.cpp
${CMAKE_SOURCE_DIR}/lib/transport/if_addrs.cpp
${CMAKE_SOURCE_DIR}/lib/transport/udp_simple.cpp
${CMAKE_SOURCE_DIR}/lib/transport/udp_zero_copy_asio.cpp