aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/transport/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-06-09 00:54:35 +0000
committerJosh Blum <josh@joshknows.com>2010-06-09 00:54:35 +0000
commit8985d5c400a5f64dd95c0f0dcf9f793b32bd2d9c (patch)
treec038d960822b5ca153f4bbf6a4bad075467a2a1f /host/lib/transport/CMakeLists.txt
parentcd84a19214ea03a3615b5ac7997f33fcfc9870ae (diff)
parent8c7b73ee536357d2f7efc4558b531575fa28ca31 (diff)
downloaduhd-8985d5c400a5f64dd95c0f0dcf9f793b32bd2d9c.tar.gz
uhd-8985d5c400a5f64dd95c0f0dcf9f793b32bd2d9c.tar.bz2
uhd-8985d5c400a5f64dd95c0f0dcf9f793b32bd2d9c.zip
Merge branch 'master' of ettus.sourcerepo.com:ettus/uhdpriv into usrp_e
Diffstat (limited to 'host/lib/transport/CMakeLists.txt')
-rw-r--r--host/lib/transport/CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/host/lib/transport/CMakeLists.txt b/host/lib/transport/CMakeLists.txt
index a74f7d527..872865d6c 100644
--- a/host/lib/transport/CMakeLists.txt
+++ b/host/lib/transport/CMakeLists.txt
@@ -44,8 +44,12 @@ LIBUHD_PYTHON_GEN_SOURCE(
${CMAKE_BINARY_DIR}/lib/transport/vrt.cpp
)
+LIBUHD_PYTHON_GEN_SOURCE(
+ ${CMAKE_SOURCE_DIR}/lib/transport/gen_convert_types.py
+ ${CMAKE_BINARY_DIR}/lib/transport/convert_types.cpp
+)
+
LIBUHD_APPEND_SOURCES(
- ${CMAKE_SOURCE_DIR}/lib/transport/convert_types.cpp
${CMAKE_SOURCE_DIR}/lib/transport/if_addrs.cpp
${CMAKE_SOURCE_DIR}/lib/transport/udp_simple.cpp
${CMAKE_SOURCE_DIR}/lib/transport/udp_zero_copy_asio.cpp