aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/transport/CMakeLists.txt
diff options
context:
space:
mode:
authorCiro Nishiguchi <ciro.nishiguchi@ni.com>2019-09-11 14:48:50 -0500
committerMartin Braun <martin.braun@ettus.com>2019-11-26 12:21:31 -0800
commit650c07cbcb74b88e1a561a85e25035e553e00f14 (patch)
tree4085d562123f3ea4e20e70a2b326dcfb3b3674da /host/lib/transport/CMakeLists.txt
parentf3a86a32944ae68047e6f64369e93a6830742601 (diff)
downloaduhd-650c07cbcb74b88e1a561a85e25035e553e00f14.tar.gz
uhd-650c07cbcb74b88e1a561a85e25035e553e00f14.tar.bz2
uhd-650c07cbcb74b88e1a561a85e25035e553e00f14.zip
transport: Implement an I/O service that uses an offload thread
The offload_io_service executes another I/O service instance within an offload thread, and provides synchronization mechanisms to communicate with clients. Frame buffers are passed from the offload thread to the client and back via single-producer, single-consumer queues.
Diffstat (limited to 'host/lib/transport/CMakeLists.txt')
-rw-r--r--host/lib/transport/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/lib/transport/CMakeLists.txt b/host/lib/transport/CMakeLists.txt
index d21644f01..d39ca7336 100644
--- a/host/lib/transport/CMakeLists.txt
+++ b/host/lib/transport/CMakeLists.txt
@@ -123,6 +123,7 @@ LIBUHD_APPEND_SOURCES(
${CMAKE_CURRENT_SOURCE_DIR}/muxed_zero_copy_if.cpp
${CMAKE_CURRENT_SOURCE_DIR}/zero_copy_flow_ctrl.cpp
${CMAKE_CURRENT_SOURCE_DIR}/inline_io_service.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/offload_io_service.cpp
${CMAKE_CURRENT_SOURCE_DIR}/adapter.cpp
)