aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/transport/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-11-23 13:50:37 -0800
committerJosh Blum <josh@joshknows.com>2010-11-23 13:50:37 -0800
commit30ce5acedd3e0dc6fc97d7597781a0a4828812f2 (patch)
tree28d010c0938121f587e1820849c34ee900e7f74b /host/lib/transport/CMakeLists.txt
parent8ce75a3ca7a51f4bdee87d78a610a0f2519473ae (diff)
parent13ae4786e091d5581baf31c9967dca822ef15e39 (diff)
downloaduhd-30ce5acedd3e0dc6fc97d7597781a0a4828812f2.tar.gz
uhd-30ce5acedd3e0dc6fc97d7597781a0a4828812f2.tar.bz2
uhd-30ce5acedd3e0dc6fc97d7597781a0a4828812f2.zip
Merge branch 'usrp_e100' into next
Conflicts: images/Makefile
Diffstat (limited to 'host/lib/transport/CMakeLists.txt')
-rw-r--r--host/lib/transport/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/host/lib/transport/CMakeLists.txt b/host/lib/transport/CMakeLists.txt
index b9ec7a6ad..b95d46381 100644
--- a/host/lib/transport/CMakeLists.txt
+++ b/host/lib/transport/CMakeLists.txt
@@ -58,6 +58,12 @@ IF(HAVE_EMMINTRIN_H)
ADD_DEFINITIONS(-DHAVE_EMMINTRIN_H)
ENDIF(HAVE_EMMINTRIN_H)
+INCLUDE(CheckIncludeFileCXX)
+CHECK_INCLUDE_FILE_CXX(arm_neon.h HAVE_ARM_NEON_H)
+
+IF(HAVE_ARM_NEON_H)
+ ADD_DEFINITIONS(-DHAVE_ARM_NEON_H)
+ENDIF(HAVE_ARM_NEON_H)
########################################################################
# Setup defines for interface address discovery
########################################################################