aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/rfnoc/nocscript/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2018-11-13 21:53:22 -0800
committerBrent Stapleton <bstapleton@g.hmc.edu>2018-11-14 14:10:09 -0800
commita69ab0c23a0c38e3fed3e412df36538d8959d23c (patch)
treee6669a138dad84f79c46588f43a38c69dda90246 /host/lib/rfnoc/nocscript/CMakeLists.txt
parent4247f025020d7dd1f696dfbd3cce248957d6ace7 (diff)
downloaduhd-a69ab0c23a0c38e3fed3e412df36538d8959d23c.tar.gz
uhd-a69ab0c23a0c38e3fed3e412df36538d8959d23c.tar.bz2
uhd-a69ab0c23a0c38e3fed3e412df36538d8959d23c.zip
cmake: Update coding style to use lowercase commands
Also updates our coding style file. Ancient CMake versions required upper-case commands. Later command names became case-insensitive. Now the preferred style is lower-case. Run the following shell code (with GNU compliant sed): cmake --help-command-list | grep -v "cmake version" | while read c; do echo 's/\b'"$(echo $c | tr '[:lower:]' '[:upper:]')"'\(\s*\)(/'"$c"'\1(/g' done > convert.sed \ && git ls-files -z -- bootstrap '*.cmake' '*.cmake.in' \ '*CMakeLists.txt' | xargs -0 gsed -i -f convert.sed && rm convert.sed (Make sure the backslashes don't get mangled!)
Diffstat (limited to 'host/lib/rfnoc/nocscript/CMakeLists.txt')
-rw-r--r--host/lib/rfnoc/nocscript/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/host/lib/rfnoc/nocscript/CMakeLists.txt b/host/lib/rfnoc/nocscript/CMakeLists.txt
index 503bd5e03..8fb7215ad 100644
--- a/host/lib/rfnoc/nocscript/CMakeLists.txt
+++ b/host/lib/rfnoc/nocscript/CMakeLists.txt
@@ -5,19 +5,19 @@
# SPDX-License-Identifier: GPL-3.0
#
-INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
-INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR})
+include_directories(${CMAKE_CURRENT_SOURCE_DIR})
+include_directories(${CMAKE_CURRENT_BINARY_DIR})
LIBUHD_PYTHON_GEN_SOURCE(
${CMAKE_CURRENT_SOURCE_DIR}/gen_basic_funcs.py
${CMAKE_CURRENT_BINARY_DIR}/basic_functions.hpp
)
-IF(ENABLE_MANUAL)
+if(ENABLE_MANUAL)
LIBUHD_PYTHON_GEN_SOURCE(
${CMAKE_CURRENT_SOURCE_DIR}/gen_basic_funcs.py
${CMAKE_BINARY_DIR}/docs/nocscript_functions.dox
)
-ENDIF(ENABLE_MANUAL)
+endif(ENABLE_MANUAL)
LIBUHD_APPEND_SOURCES(
${CMAKE_CURRENT_SOURCE_DIR}/expression.cpp