aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/rfnoc/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2019-05-24 14:46:39 -0700
committerMartin Braun <martin.braun@ettus.com>2019-11-26 11:49:16 -0800
commit1ed37cdfda93e430037ee4028ec5ac70ab223b1b (patch)
tree16c20409cf18b0747b107092ed64c3beab4f6e89 /host/lib/rfnoc/CMakeLists.txt
parentde6dfccc835ad46b5f4362caae66a37651716ab2 (diff)
downloaduhd-1ed37cdfda93e430037ee4028ec5ac70ab223b1b.tar.gz
uhd-1ed37cdfda93e430037ee4028ec5ac70ab223b1b.tar.bz2
uhd-1ed37cdfda93e430037ee4028ec5ac70ab223b1b.zip
rfnoc: Add block registry/factory and make_args
- noc_block_base now has a ctor defined - The registry stores factory functions to the individual Noc-Block implementations
Diffstat (limited to 'host/lib/rfnoc/CMakeLists.txt')
-rw-r--r--host/lib/rfnoc/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/host/lib/rfnoc/CMakeLists.txt b/host/lib/rfnoc/CMakeLists.txt
index 2c13c1819..57a5253a7 100644
--- a/host/lib/rfnoc/CMakeLists.txt
+++ b/host/lib/rfnoc/CMakeLists.txt
@@ -1,6 +1,7 @@
#
# Copyright 2014-2015,2017 Ettus Research LLC
# Copyright 2018 Ettus Research, a National Instruments Company
+# Copyright 2019 Ettus Research, a National Instruments Brand
#
# SPDX-License-Identifier: GPL-3.0-or-later
#
@@ -30,6 +31,7 @@ LIBUHD_APPEND_SOURCES(
${CMAKE_CURRENT_SOURCE_DIR}/rate_node_ctrl.cpp
${CMAKE_CURRENT_SOURCE_DIR}/ctrlport_endpoint.cpp
${CMAKE_CURRENT_SOURCE_DIR}/chdr_ctrl_endpoint.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/registry_factory.cpp
${CMAKE_CURRENT_SOURCE_DIR}/rx_stream_terminator.cpp
${CMAKE_CURRENT_SOURCE_DIR}/scalar_node_ctrl.cpp
${CMAKE_CURRENT_SOURCE_DIR}/sink_block_ctrl_base.cpp