aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/rc/CMakeLists.txt
diff options
context:
space:
mode:
authorLars Amsel <lars.amsel@ni.com>2021-06-04 08:27:50 +0200
committerAaron Rossetto <aaron.rossetto@ni.com>2021-06-10 12:01:53 -0500
commit2a575bf9b5a4942f60e979161764b9e942699e1e (patch)
tree2f0535625c30025559ebd7494a4b9e7122550a73 /host/lib/rc/CMakeLists.txt
parente17916220cc955fa219ae37f607626ba88c4afe3 (diff)
downloaduhd-2a575bf9b5a4942f60e979161764b9e942699e1e.tar.gz
uhd-2a575bf9b5a4942f60e979161764b9e942699e1e.tar.bz2
uhd-2a575bf9b5a4942f60e979161764b9e942699e1e.zip
uhd: Add support for the USRP X410
Co-authored-by: Lars Amsel <lars.amsel@ni.com> Co-authored-by: Michael Auchter <michael.auchter@ni.com> Co-authored-by: Martin Braun <martin.braun@ettus.com> Co-authored-by: Paul Butler <paul.butler@ni.com> Co-authored-by: Cristina Fuentes <cristina.fuentes-curiel@ni.com> Co-authored-by: Humberto Jimenez <humberto.jimenez@ni.com> Co-authored-by: Virendra Kakade <virendra.kakade@ni.com> Co-authored-by: Lane Kolbly <lane.kolbly@ni.com> Co-authored-by: Max Köhler <max.koehler@ni.com> Co-authored-by: Andrew Lynch <andrew.lynch@ni.com> Co-authored-by: Grant Meyerhoff <grant.meyerhoff@ni.com> Co-authored-by: Ciro Nishiguchi <ciro.nishiguchi@ni.com> Co-authored-by: Thomas Vogel <thomas.vogel@ni.com>
Diffstat (limited to 'host/lib/rc/CMakeLists.txt')
-rw-r--r--host/lib/rc/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/host/lib/rc/CMakeLists.txt b/host/lib/rc/CMakeLists.txt
index 52b6693c0..33dc8540b 100644
--- a/host/lib/rc/CMakeLists.txt
+++ b/host/lib/rc/CMakeLists.txt
@@ -8,6 +8,18 @@ include(CMakeRC)
cmrc_add_resource_library(uhd-resources
ALIAS uhd_rc
NAMESPACE rc
+# calibration data test file
cal/test.cal
+# ZBX revB/C TX calibration data
+ cal/x4xx_pwr_zbx_tx_0_tx+rx0.cal
+ cal/x4xx_pwr_zbx_tx_1_tx+rx0.cal
+# ZBX revB/C RX calibration data
+ cal/x4xx_pwr_zbx_rx_0_tx+rx0.cal
+ cal/x4xx_pwr_zbx_rx_1_tx+rx0.cal
+ cal/x4xx_pwr_zbx_rx_0_rx1.cal
+ cal/x4xx_pwr_zbx_rx_1_rx1.cal
+# ZBX DSA data
+ cal/zbx_dsa_tx.cal
+ cal/zbx_dsa_rx.cal
)
set_property(TARGET uhd-resources PROPERTY POSITION_INDEPENDENT_CODE ON)