aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/include/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2017-08-24 14:37:08 -0700
committerMartin Braun <martin.braun@ettus.com>2018-03-05 13:53:45 -0800
commit347bb79d2adef4b5bf3e3a94577ecc18c0408519 (patch)
tree9812aa2b939c8697abd91218bda5c0d1dd1131c3 /host/lib/include/CMakeLists.txt
parent988b6ecab417dc8e5ac225e112b33c2b2f6193ad (diff)
downloaduhd-347bb79d2adef4b5bf3e3a94577ecc18c0408519.tar.gz
uhd-347bb79d2adef4b5bf3e3a94577ecc18c0408519.tar.bz2
uhd-347bb79d2adef4b5bf3e3a94577ecc18c0408519.zip
uhd: Removed atomic.hpp from public API
atomic.hpp defines a spin lock and a lockfree mutex. There is no reason to have standard constructs in the public API, where we're contractually obligated to not touch them. Thus, moving them into the internal API space.
Diffstat (limited to 'host/lib/include/CMakeLists.txt')
-rw-r--r--host/lib/include/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/host/lib/include/CMakeLists.txt b/host/lib/include/CMakeLists.txt
index 5eea68f80..a688f4ea9 100644
--- a/host/lib/include/CMakeLists.txt
+++ b/host/lib/include/CMakeLists.txt
@@ -1,7 +1,7 @@
#
-# Copyright 2017 Ettus Research, a National Instruments Company
+# Copyright 2017 Ettus Research (National Instruments Corp.)
#
-# SPDX-License-Identifier: GPL-3.0
+# SPDX-License-Identifier: GPL-3.0+
#
INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})