aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/ic_reg_maps/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-02-25 15:23:01 -0800
committerJosh Blum <josh@joshknows.com>2011-02-25 15:23:01 -0800
commitf57ef3e745c85645faa3e9fd340b16bddfebb0ae (patch)
treeac7996f7adbcada8ed9bd3bbb8d7c2cf2bbc6a10 /host/lib/ic_reg_maps/CMakeLists.txt
parenteef4216ca7073868fb6cf15e5d6c8b75e1576538 (diff)
downloaduhd-f57ef3e745c85645faa3e9fd340b16bddfebb0ae.tar.gz
uhd-f57ef3e745c85645faa3e9fd340b16bddfebb0ae.tar.bz2
uhd-f57ef3e745c85645faa3e9fd340b16bddfebb0ae.zip
uhd: make ic reg maps depend on common.py
Diffstat (limited to 'host/lib/ic_reg_maps/CMakeLists.txt')
-rw-r--r--host/lib/ic_reg_maps/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/host/lib/ic_reg_maps/CMakeLists.txt b/host/lib/ic_reg_maps/CMakeLists.txt
index 67a63c32b..9e1f4705e 100644
--- a/host/lib/ic_reg_maps/CMakeLists.txt
+++ b/host/lib/ic_reg_maps/CMakeLists.txt
@@ -1,5 +1,5 @@
#
-# Copyright 2010 Ettus Research LLC
+# Copyright 2010-2011 Ettus Research LLC
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -20,6 +20,7 @@
########################################################################
INCLUDE_DIRECTORIES(${CMAKE_CURRENT_BINARY_DIR})
+SET(LIBUHD_PYTHON_GEN_SOURCE_DEPS ${CMAKE_CURRENT_SOURCE_DIR}/common.py)
LIBUHD_PYTHON_GEN_SOURCE(
${CMAKE_CURRENT_SOURCE_DIR}/gen_adf4350_regs.py
@@ -90,3 +91,5 @@ LIBUHD_PYTHON_GEN_SOURCE(
${CMAKE_CURRENT_SOURCE_DIR}/gen_tuner_4937di5_regs.py
${CMAKE_CURRENT_BINARY_DIR}/tuner_4937di5_regs.hpp
)
+
+UNSET(LIBUHD_PYTHON_GEN_SOURCE_DEPS)