aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/features/CMakeLists.txt
diff options
context:
space:
mode:
authorLane Kolbly <lane.kolbly@ni.com>2020-06-22 18:06:38 -0500
committerAaron Rossetto <aaron.rossetto@ni.com>2020-06-25 13:36:08 -0500
commitd6cb55ef08f51c9ebef57e5bbcb95b03a65972a9 (patch)
tree8b8f1350d9d45d513f00e2b8e836a52600d27e66 /host/lib/features/CMakeLists.txt
parente9ae5fb949903cce1720b75b894401930cce1ebe (diff)
downloaduhd-d6cb55ef08f51c9ebef57e5bbcb95b03a65972a9.tar.gz
uhd-d6cb55ef08f51c9ebef57e5bbcb95b03a65972a9.tar.bz2
uhd-d6cb55ef08f51c9ebef57e5bbcb95b03a65972a9.zip
uhd: Create discoverable feature registry implementation
Classes which want to implement discoverable_feature can simply inherit from this registry and get access to an ergonomic map-backed registry of features.
Diffstat (limited to 'host/lib/features/CMakeLists.txt')
-rw-r--r--host/lib/features/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/host/lib/features/CMakeLists.txt b/host/lib/features/CMakeLists.txt
new file mode 100644
index 000000000..2cdd1dd56
--- /dev/null
+++ b/host/lib/features/CMakeLists.txt
@@ -0,0 +1,12 @@
+#
+# Copyright 2020 Ettus Research, a National Instruments Brand
+#
+# SPDX-License-Identifier: GPL-3.0-or-later
+#
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+LIBUHD_APPEND_SOURCES(
+ ${CMAKE_CURRENT_SOURCE_DIR}/discoverable_feature_registry.cpp
+)