aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/experts/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2018-01-31 20:20:14 +0100
committerMartin Braun <martin.braun@ettus.com>2018-03-14 15:17:44 -0700
commit6652eb4a033b38bd952563f3544eb11e98f27327 (patch)
treec1b0af72cbaceaa1df462f18194f4063fb13ae17 /host/lib/experts/CMakeLists.txt
parent86b95486ed6d68e2772d79f20feddbef5439981b (diff)
downloaduhd-6652eb4a033b38bd952563f3544eb11e98f27327.tar.gz
uhd-6652eb4a033b38bd952563f3544eb11e98f27327.tar.bz2
uhd-6652eb4a033b38bd952563f3544eb11e98f27327.zip
uhd: Move internal headers to uhdlib/
To avoid the proliferation of additional include directories and multiple ways of including project-local headers, we now default to moving all headers that are used across UHD into the uhdlib/ subdirectory. Some #include statements were also reordered as they were modified for closer compliance with the coding guidelines. Internal cpp source files should now include files like this: #include <uhdlib/rfnoc/ctrl_iface.hpp> Reviewed-by: Ashish Chaudhari <ashish.chaudhari@ettus.com>
Diffstat (limited to 'host/lib/experts/CMakeLists.txt')
-rw-r--r--host/lib/experts/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/host/lib/experts/CMakeLists.txt b/host/lib/experts/CMakeLists.txt
index 2c72721a4..3101a7330 100644
--- a/host/lib/experts/CMakeLists.txt
+++ b/host/lib/experts/CMakeLists.txt
@@ -8,8 +8,6 @@
########################################################################
# This file included, use CMake directory variables
########################################################################
-INCLUDE_DIRECTORIES(${CMAKE_CURRENT_SOURCE_DIR})
-
LIBUHD_APPEND_SOURCES(
${CMAKE_CURRENT_SOURCE_DIR}/expert_container.cpp
${CMAKE_CURRENT_SOURCE_DIR}/expert_factory.cpp