aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/convert/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2011-11-15 06:12:28 +0000
committerJosh Blum <josh@joshknows.com>2011-11-15 06:12:28 +0000
commitaed619727e47bf2353164ac1788a6e3479b2fe16 (patch)
tree3822cdf56344d8af2974ae4379d5bed0d36cefca /host/lib/convert/CMakeLists.txt
parent986f6f8d0b14c4e56468c1c8887fadb2dc4e1463 (diff)
downloaduhd-aed619727e47bf2353164ac1788a6e3479b2fe16.tar.gz
uhd-aed619727e47bf2353164ac1788a6e3479b2fe16.tar.bz2
uhd-aed619727e47bf2353164ac1788a6e3479b2fe16.zip
convert: move priorities to implementation, different for arm
Diffstat (limited to 'host/lib/convert/CMakeLists.txt')
-rw-r--r--host/lib/convert/CMakeLists.txt6
1 files changed, 1 insertions, 5 deletions
diff --git a/host/lib/convert/CMakeLists.txt b/host/lib/convert/CMakeLists.txt
index 1fe92d93a..98907dc29 100644
--- a/host/lib/convert/CMakeLists.txt
+++ b/host/lib/convert/CMakeLists.txt
@@ -91,11 +91,7 @@ IF(CMAKE_COMPILER_IS_GNUCXX)
UNSET(CMAKE_REQUIRED_FLAGS)
ENDIF(CMAKE_COMPILER_IS_GNUCXX)
-IF(HAVE_ARM_NEON_H AND ENABLE_ORC)
- #prefer orc support, its faster than the current intrinsic implementations
- MESSAGE(STATUS "Enabled conversion support with ORC.")
-ELSEIF(HAVE_ARM_NEON_H)
- MESSAGE(STATUS "Enabled conversion support with NEON intrinsics.")
+IF(HAVE_ARM_NEON_H)
SET_SOURCE_FILES_PROPERTIES(
${CMAKE_CURRENT_SOURCE_DIR}/convert_with_neon.cpp
PROPERTIES COMPILE_FLAGS "${NEON_FLAGS}"