aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/cal/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2020-03-05 11:35:14 -0800
committerAaron Rossetto <aaron.rossetto@ni.com>2020-03-26 07:46:03 -0500
commitf13615ec140aec508501d21a21190782318c360a (patch)
tree5a906ffd6bfd4c319df539c0d31449bd1bd80014 /host/lib/cal/CMakeLists.txt
parent8055879242b43500c49e8ea8d4035687d13f9fae (diff)
downloaduhd-f13615ec140aec508501d21a21190782318c360a.tar.gz
uhd-f13615ec140aec508501d21a21190782318c360a.tar.bz2
uhd-f13615ec140aec508501d21a21190782318c360a.zip
uhd: cal: Add database class
This class contains methods to store and retrieve data from the local calibration database. Note that in this case, the "database" is just a bunch of files on the local filesystem.
Diffstat (limited to 'host/lib/cal/CMakeLists.txt')
-rw-r--r--host/lib/cal/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/host/lib/cal/CMakeLists.txt b/host/lib/cal/CMakeLists.txt
new file mode 100644
index 000000000..5c2c8a617
--- /dev/null
+++ b/host/lib/cal/CMakeLists.txt
@@ -0,0 +1,13 @@
+#
+# Copyright 2020 Ettus Research, a National Instruments Brand
+#
+# SPDX-License-Identifier: GPL-3.0-or-later
+#
+
+########################################################################
+# This file included, use CMake directory variables
+########################################################################
+LIBUHD_APPEND_SOURCES(
+ ${CMAKE_CURRENT_SOURCE_DIR}/database.cpp
+)
+