aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-04-21 15:46:16 -0700
committerJosh Blum <josh@joshknows.com>2010-04-21 15:46:16 -0700
commitd91c18e6d061cf4584e271508a7a4475d8224663 (patch)
treedb51a9cb385f870a8d47afc5c17875bc30a1664c /host/lib/CMakeLists.txt
parent72f4ce79c88d03b33d585a2ea48076e2010a21a8 (diff)
downloaduhd-d91c18e6d061cf4584e271508a7a4475d8224663.tar.gz
uhd-d91c18e6d061cf4584e271508a7a4475d8224663.tar.bz2
uhd-d91c18e6d061cf4584e271508a7a4475d8224663.zip
xcvr work, skeleton layout
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 7cb74d30a..d43a61010 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -54,8 +54,6 @@ SET(libuhd_sources
transport/convert_types.cpp
transport/if_addrs.cpp
transport/udp_simple.cpp
- usrp/dboard/db_basic_and_lf.cpp
- usrp/dboard/db_rfx.cpp
usrp/dboard_base.cpp
usrp/simple_usrp.cpp
usrp/dboard_manager.cpp
@@ -114,6 +112,15 @@ UHD_PYTHON_GEN_SOURCE_FILE(
)
########################################################################
+# Add dboard sources
+########################################################################
+LIST(APPEND libuhd_sources
+ usrp/dboard/db_basic_and_lf.cpp
+ usrp/dboard/db_rfx.cpp
+ usrp/dboard/db_xcvr2450.cpp
+)
+
+########################################################################
# Add usrp2 sources
########################################################################
LIST(APPEND libuhd_sources