aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-03-21 00:58:34 -0700
committerJosh Blum <josh@joshknows.com>2010-03-21 00:58:34 -0700
commitd1ecc555e53770f1a5608000352f56f48c36c310 (patch)
treeccccaac506fa6fe0812fce202121a4ad85d3f752 /host/lib/CMakeLists.txt
parent26ada5ee709fc4d7e195d19720b467c14368bc05 (diff)
downloaduhd-d1ecc555e53770f1a5608000352f56f48c36c310.tar.gz
uhd-d1ecc555e53770f1a5608000352f56f48c36c310.tar.bz2
uhd-d1ecc555e53770f1a5608000352f56f48c36c310.zip
Moved typedefs from props.hpp into new file types.hpp.
Created structs to replace range tuples, and clock config struct. Merged clock config props into one property using config struct. Added templated dict construction to use the assign::map_list_of. Added gcc flag to set visibility to hidden and use the api macro.
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 875a065af..563ffb340 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -25,6 +25,7 @@ SET(libuhd_sources
metadata.cpp
simple_device.cpp
time_spec.cpp
+ types.cpp
wax.cpp
transport/udp_simple.cpp
transport/vrt.cpp
@@ -44,7 +45,7 @@ SET(libuhd_sources
# Conditionally add the udp sources
########################################################################
LIST(APPEND libuhd_sources
- transport/udp_zero_copy_none.cpp
+ transport/udp_zero_copy_asio.cpp
)
########################################################################