aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorNicholas Corgan <nicholas.corgan@ni.com>2019-04-29 20:22:39 -0500
committerMartin Braun <martin.braun@ettus.com>2019-05-02 08:36:44 -0700
commit918e4ff20c4e843b5b32d27274fbe558ec1b0000 (patch)
tree445f6ab9c2b7cfaaafeed2b606fe1ac3b63f0c2f /host/lib/CMakeLists.txt
parent436df1087b0f26ee9a3990e3a575c94e43c34293 (diff)
downloaduhd-918e4ff20c4e843b5b32d27274fbe558ec1b0000.tar.gz
uhd-918e4ff20c4e843b5b32d27274fbe558ec1b0000.tar.bz2
uhd-918e4ff20c4e843b5b32d27274fbe558ec1b0000.zip
C: Add uhd_get_abi_string, uhd_get_version_string
Clients that include the UHD C headers have access to the version and ABI #defines, but this is not available to clients that dynamically load the library. This commit adds publicly exported functions to provide this information.
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index b171cbfef..7e28399b4 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -131,6 +131,7 @@ LIBUHD_APPEND_SOURCES(
if(ENABLE_C_API)
LIBUHD_APPEND_SOURCES(
${CMAKE_CURRENT_SOURCE_DIR}/error_c.cpp
+ ${CMAKE_CURRENT_SOURCE_DIR}/version_c.cpp
)
endif(ENABLE_C_API)