aboutsummaryrefslogtreecommitdiffstats
path: root/host/lib/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-03-17 17:55:20 -0800
committerJosh Blum <josh@joshknows.com>2010-03-17 17:55:20 -0800
commit69aaffa6d8d4614dbf6b751fe058e39fced68153 (patch)
tree1a3958527b79eeb0297146dccff7fd76b0f46a7f /host/lib/CMakeLists.txt
parent83c463d09613b72817a837117c5f0b23975c8def (diff)
downloaduhd-69aaffa6d8d4614dbf6b751fe058e39fced68153.tar.gz
uhd-69aaffa6d8d4614dbf6b751fe058e39fced68153.tar.bz2
uhd-69aaffa6d8d4614dbf6b751fe058e39fced68153.zip
got uhd almost compiling in windowze. figured out special flags. also had to use boost stdint because its missing in visual c++, added a bunch of numeric casts to reduce warnings
Diffstat (limited to 'host/lib/CMakeLists.txt')
-rw-r--r--host/lib/CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/host/lib/CMakeLists.txt b/host/lib/CMakeLists.txt
index 1d2c5471b..46e1b0947 100644
--- a/host/lib/CMakeLists.txt
+++ b/host/lib/CMakeLists.txt
@@ -61,4 +61,7 @@ ADD_LIBRARY(uhd SHARED ${libuhd_sources})
TARGET_LINK_LIBRARIES(uhd ${Boost_LIBRARIES})
-INSTALL(TARGETS uhd LIBRARY DESTINATION ${LIBRARY_DIR})
+INSTALL(TARGETS uhd
+ LIBRARY DESTINATION ${LIBRARY_DIR}
+ ARCHIVE DESTINATION ${LIBRARY_DIR}
+)