aboutsummaryrefslogtreecommitdiffstats
path: root/host/examples/python/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrej Rode <andrej.rode@ettus.com>2017-02-09 11:16:16 -0800
committerMartin Braun <martin.braun@ettus.com>2018-06-20 19:02:32 -0500
commit22e24497a510c174e6de7718ad918a423d1973dd (patch)
tree436bc3d08451dbb2cc70f4c11c611cdd4ff23f78 /host/examples/python/CMakeLists.txt
parent91a5518443f4ff938f67a2f1bd1b09b24bceecd5 (diff)
downloaduhd-22e24497a510c174e6de7718ad918a423d1973dd.tar.gz
uhd-22e24497a510c174e6de7718ad918a423d1973dd.tar.bz2
uhd-22e24497a510c174e6de7718ad918a423d1973dd.zip
python: Initial commit of Python API
Initial commit of the Python API using Boost.Python. Bind the MultiUSRP API for use in Python. Bindings intended to provide as complete coverage as possible. - Wrap most multi_usrp calls - Adding multi channel send/recv examples in examples/python - Adding setuptools support - Initial attempt at binding the UHD types and filters
Diffstat (limited to 'host/examples/python/CMakeLists.txt')
-rw-r--r--host/examples/python/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/host/examples/python/CMakeLists.txt b/host/examples/python/CMakeLists.txt
new file mode 100644
index 000000000..628bf10a2
--- /dev/null
+++ b/host/examples/python/CMakeLists.txt
@@ -0,0 +1,23 @@
+#
+# Copyright 2010-2012,2015 Ettus Research LLC
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+
+SET(python_examples
+ pyuhd_rx_to_file.py
+ pyuhd_tx_waveforms.py
+)
+
+UHD_INSTALL(PROGRAMS ${python_examples} DESTINATION ${PKG_LIB_DIR}/examples COMPONENT examples)