aboutsummaryrefslogtreecommitdiffstats
path: root/host/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorAndrej Rode <andrej.rode@ettus.com>2017-02-09 11:16:16 -0800
committerMartin Braun <martin.braun@ettus.com>2018-06-20 19:02:32 -0500
commit22e24497a510c174e6de7718ad918a423d1973dd (patch)
tree436bc3d08451dbb2cc70f4c11c611cdd4ff23f78 /host/examples/CMakeLists.txt
parent91a5518443f4ff938f67a2f1bd1b09b24bceecd5 (diff)
downloaduhd-22e24497a510c174e6de7718ad918a423d1973dd.tar.gz
uhd-22e24497a510c174e6de7718ad918a423d1973dd.tar.bz2
uhd-22e24497a510c174e6de7718ad918a423d1973dd.zip
python: Initial commit of Python API
Initial commit of the Python API using Boost.Python. Bind the MultiUSRP API for use in Python. Bindings intended to provide as complete coverage as possible. - Wrap most multi_usrp calls - Adding multi channel send/recv examples in examples/python - Adding setuptools support - Initial attempt at binding the UHD types and filters
Diffstat (limited to 'host/examples/CMakeLists.txt')
-rw-r--r--host/examples/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/host/examples/CMakeLists.txt b/host/examples/CMakeLists.txt
index 56d1e4f1f..e49fcdb78 100644
--- a/host/examples/CMakeLists.txt
+++ b/host/examples/CMakeLists.txt
@@ -102,3 +102,7 @@ IF(ENABLE_C_API)
ENDFOREACH(example ${C_API_EXAMPLES})
ENDIF(HAVE_C99_STRUCTDECL)
ENDIF(ENABLE_C_API)
+
+IF(ENABLE_PYTHON_API)
+ ADD_SUBDIRECTORY(python)
+ENDIF(ENABLE_PYTHON_API)