aboutsummaryrefslogtreecommitdiffstats
path: root/host/docs/CMakeLists.txt
diff options
context:
space:
mode:
authorNicholas Corgan <nick.corgan@ettus.com>2015-08-07 10:25:27 -0700
committerMartin Braun <martin.braun@ettus.com>2015-08-07 11:23:59 -0700
commitf1ebf688291a8f3026940125b2af50e069272fd8 (patch)
treeee5811707fd80e82d68fb1167e8e36ca6bb67dd0 /host/docs/CMakeLists.txt
parentc2827e9a0bcfe9c2dd2e4dd5d68f895384564ec6 (diff)
downloaduhd-f1ebf688291a8f3026940125b2af50e069272fd8.tar.gz
uhd-f1ebf688291a8f3026940125b2af50e069272fd8.tar.bz2
uhd-f1ebf688291a8f3026940125b2af50e069272fd8.zip
C API: feature additions, bugfixes
* Wrapped uhd::device_addrs_t, added find functions for multi_usrp, multi_usrp_clock * Replaced getopt with public domain implementation * Minor bugfixes
Diffstat (limited to 'host/docs/CMakeLists.txt')
-rw-r--r--host/docs/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/host/docs/CMakeLists.txt b/host/docs/CMakeLists.txt
index 3ad2ef37c..063bfd901 100644
--- a/host/docs/CMakeLists.txt
+++ b/host/docs/CMakeLists.txt
@@ -74,7 +74,9 @@ ENDIF(LIBUHDDEV_PKG)
IF(ENABLE_DOXYGEN)
SET(ENABLE_MANUAL_OR_DOXYGEN true)
#make doxygen directory depend on the header files
- FILE(GLOB_RECURSE header_files ${CMAKE_SOURCE_DIR}/include/*.h*)
+ FILE(GLOB_RECURSE header_files ${CMAKE_SOURCE_DIR}/include/*.hpp)
+ FILE(GLOB_RECURSE h_files ${CMAKE_SOURCE_DIR}/include/*.h)
+ LIST(APPEND header_files ${h_files})
SET(DOXYGEN_DEPENDENCIES ${DOXYGEN_DEPENDENCIES} ${header_files})
IF(ENABLE_DOXYGEN_FULL)
SET(DOXYGEN_INPUT_DIRS "${DOXYGEN_INPUT_DIRS} ${CMAKE_SOURCE_DIR}/include ${CMAKE_SOURCE_DIR}/lib")