aboutsummaryrefslogtreecommitdiffstats
path: root/host/docs/CMakeLists.txt
diff options
context:
space:
mode:
authorJosh Blum <josh@joshknows.com>2010-04-18 14:55:05 -0700
committerJosh Blum <josh@joshknows.com>2010-04-18 14:55:05 -0700
commitb3d0c68ceaff1562c32fb8fe41c1e6845a0aad37 (patch)
treef896520f4ed76405b5ddab4e0f8660f610670b12 /host/docs/CMakeLists.txt
parent77c578fc639bb3d54c6730402de04a22636b1d6d (diff)
downloaduhd-b3d0c68ceaff1562c32fb8fe41c1e6845a0aad37.tar.gz
uhd-b3d0c68ceaff1562c32fb8fe41c1e6845a0aad37.tar.bz2
uhd-b3d0c68ceaff1562c32fb8fe41c1e6845a0aad37.zip
added usrp2 networking notes, tweaked style and build
Diffstat (limited to 'host/docs/CMakeLists.txt')
-rw-r--r--host/docs/CMakeLists.txt17
1 files changed, 14 insertions, 3 deletions
diff --git a/host/docs/CMakeLists.txt b/host/docs/CMakeLists.txt
index e90f1e9a1..52376fe8c 100644
--- a/host/docs/CMakeLists.txt
+++ b/host/docs/CMakeLists.txt
@@ -31,16 +31,24 @@ MESSAGE(STATUS "Checking for rst2html (docutils)")
FIND_PROGRAM(RST2HTML rst2html)
IF(${RST2HTML} STREQUAL "RST2HTML-NOTFOUND")
MESSAGE(STATUS "Checking for rst2html (docutils) - not found")
+ MESSAGE(STATUS " Disabled generation of HTML manual.")
ELSE(${RST2HTML} STREQUAL "RST2HTML-NOTFOUND")
MESSAGE(STATUS "Checking for rst2html (docutils) - found")
+ MESSAGE(STATUS " Enabled generation of HTML manual.")
+ SET(stylesheet ${CMAKE_CURRENT_SOURCE_DIR}/style.css)
+ SET(rst2html_options
+ --stylesheet=${stylesheet}
+ --no-toc-backlinks
+ --date
+ --time
+ )
FOREACH(rstfile ${manual_sources})
SET(rstfile ${CMAKE_CURRENT_SOURCE_DIR}/${rstfile})
GET_FILENAME_COMPONENT(rstfile_we ${rstfile} NAME_WE)
SET(htmlfile ${CMAKE_CURRENT_BINARY_DIR}/${rstfile_we}.html)
ADD_CUSTOM_COMMAND(
- OUTPUT ${htmlfile} DEPENDS ${rstfile} ${CMAKE_CURRENT_SOURCE_DIR}/style.css
- COMMAND ${RST2HTML} ${rstfile} ${htmlfile}
- --stylesheet=${CMAKE_CURRENT_SOURCE_DIR}/style.css --no-toc-backlinks
+ OUTPUT ${htmlfile} DEPENDS ${rstfile} ${stylesheet}
+ COMMAND ${RST2HTML} ${rstfile} ${htmlfile} ${rst2html_options}
COMMENT "Generating ${htmlfile}"
)
LIST(APPEND manual_html_files ${htmlfile})
@@ -57,6 +65,7 @@ INSTALL(FILES ${manual_sources} DESTINATION ${PKG_DOC_DIR}/manual/rst)
INCLUDE(FindDoxygen)
IF(DOXYGEN_FOUND)
+ MESSAGE(STATUS " Enabled generation of Doxygen documentation.")
SET(CMAKE_CURRENT_BINARY_DIR_DOXYGEN ${CMAKE_CURRENT_BINARY_DIR}/doxygen)
CONFIGURE_FILE(
${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in
@@ -68,4 +77,6 @@ IF(DOXYGEN_FOUND)
)
ADD_CUSTOM_TARGET(doxygen_html ALL DEPENDS ${CMAKE_CURRENT_BINARY_DIR_DOXYGEN})
INSTALL(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR_DOXYGEN} DESTINATION ${PKG_DOC_DIR})
+ELSE(DOXYGEN_FOUND)
+ MESSAGE(STATUS " Disabled generation of Doxygen documentation.")
ENDIF(DOXYGEN_FOUND)