aboutsummaryrefslogtreecommitdiffstats
path: root/host/cmake/debian/rules
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2015-12-30 14:22:43 -0800
committerMartin Braun <martin.braun@ettus.com>2015-12-30 14:22:43 -0800
commitdb9ebd80dd0d675b2018f1ac504745e9bd110cd9 (patch)
treedbc101179c60313deb81a75f059218624fec0225 /host/cmake/debian/rules
parent867d2223d18c2127ade5fd6a79b0be921f0ca4ee (diff)
parent605b360651e85ca5923d0e9e8ea20343f7202301 (diff)
downloaduhd-db9ebd80dd0d675b2018f1ac504745e9bd110cd9.tar.gz
uhd-db9ebd80dd0d675b2018f1ac504745e9bd110cd9.tar.bz2
uhd-db9ebd80dd0d675b2018f1ac504745e9bd110cd9.zip
Merge branch 'maint'
Diffstat (limited to 'host/cmake/debian/rules')
-rwxr-xr-xhost/cmake/debian/rules20
1 files changed, 20 insertions, 0 deletions
diff --git a/host/cmake/debian/rules b/host/cmake/debian/rules
new file mode 100755
index 000000000..842e5247f
--- /dev/null
+++ b/host/cmake/debian/rules
@@ -0,0 +1,20 @@
+#!/usr/bin/make -f
+DEB_HOST_MULTIARCH ?= $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
+export DEB_HOST_MULTIARCH
+
+%:
+ dh $@ --parallel --sourcedirectory=host --builddirectory=build
+
+override_dh_auto_configure:
+ dh_auto_configure -- -DLIB_SUFFIX="/$(DEB_HOST_MULTIARCH)" -DPKG_LIB_DIR="/usr/lib/uhd" -DUHD_RELEASE_MODE="release"
+
+# The test suite for this package is busted on powerpc.
+override_dh_auto_test:
+ - if [ $(DEB_BUILD_ARCH) != powerpc ]; then dh_auto_test; fi
+
+override_dh_auto_install:
+ cp debian/uhd-host.limits debian/uhd-host/etc/security/limits.d/uhd.conf
+ cp debian/uhd-host.sysctl debian/uhd-host/etc/sysctl.d/uhd-usrp2.conf
+ dh_auto_install
+ - rm -f debian/tmp/usr/share/doc/uhd/doxygen/html/jquery.js
+ ln -s /usr/share/javascript/jquery/jquery.js debian/tmp/usr/share/doc/uhd/doxygen/html/jquery.js