aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorMartin Braun <martin.braun@ettus.com>2019-09-28 13:13:41 +0200
committerMartin Braun <martin.braun@ettus.com>2019-11-26 12:21:32 -0800
commitf773cf9fb96e25d064f43cffdc893ac905d91f15 (patch)
treeb9aab514b0289687dcc006a831c832a53051f34d /host/CMakeLists.txt
parentfcc2e9c602a6103dfd0f75e035f614b177c5dc35 (diff)
downloaduhd-f773cf9fb96e25d064f43cffdc893ac905d91f15.tar.gz
uhd-f773cf9fb96e25d064f43cffdc893ac905d91f15.tar.bz2
uhd-f773cf9fb96e25d064f43cffdc893ac905d91f15.zip
uhd: Replace boost::regex with std::regex
boost::regex was a requirement until the minimum version of gcc was increased. Since it is at version 5.3 now, using Boost.Regex is no longer necessary. This change is a pure search-and-replace; Boost and std versions of regex are compatible and use the same syntax.
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 53e5cba7e..55110e12a 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -287,7 +287,6 @@ set(UHD_BOOST_REQUIRED_COMPONENTS
date_time
filesystem
program_options
- regex
system
unit_test_framework
serialization