aboutsummaryrefslogtreecommitdiffstats
path: root/host/CMakeLists.txt
diff options
context:
space:
mode:
authorMark Meserve <mark.meserve@ni.com>2017-03-21 13:30:18 -0500
committerMartin Braun <martin.braun@ettus.com>2017-03-21 18:00:45 -0700
commitbfc2546a32d359b492ffd0acefe5ad760080bd5e (patch)
treeedd3b8e696d20552a3d777518a99323876ae1922 /host/CMakeLists.txt
parent1b5f4ab3bfc53090d274d69053bf75537f1c08ed (diff)
downloaduhd-bfc2546a32d359b492ffd0acefe5ad760080bd5e.tar.gz
uhd-bfc2546a32d359b492ffd0acefe5ad760080bd5e.tar.bz2
uhd-bfc2546a32d359b492ffd0acefe5ad760080bd5e.zip
msvc build: set compile_flags instead of add_definitions
Diffstat (limited to 'host/CMakeLists.txt')
-rw-r--r--host/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/host/CMakeLists.txt b/host/CMakeLists.txt
index 90df674b0..30a05ef9c 100644
--- a/host/CMakeLists.txt
+++ b/host/CMakeLists.txt
@@ -222,8 +222,8 @@ IF(MSVC)
-D_CRT_NONSTDC_NO_DEPRECATE
-D_WINSOCK_DEPRECATED_NO_WARNINGS
)
- ADD_DEFINITIONS(/MP) #multi-threaded build
- ADD_DEFINITIONS(/bigobj) #Increases the number of addressable sections in an .obj file.
+ # multi-threaded build and increases the number of addressable sections in an .obj file.
+ SET (COMPILE_FLAGS ${COMPILE_FLAGS} /MP /bigobj)
ENDIF(MSVC)
IF(CYGWIN)